Am backing up daily my DB with pg_dump. The strange issue is that when I try to restore it with psql, errors are thrown. After opening the dump file with vim and analyzing the line that is causing the error, it is clear that there is some C source code being written to the file. Not only one, but chunks of them.

How could this happen? Any way to avoid it?

The dump is done through the postgresql webmin module.

I'm using PostgreSQL 9.3.

  • "errors are thrown". Those errors are ....? If it's too big to paste here, include it in a pastebin link. Also show the pg_dump command line you use, exactly. If you run pg_dump directly instead of via webmin, what happens? Jan 28, 2014 at 7:06
  • Just tried to dump and restore from the command line and it worked perfectly! I think it is some sort of issue with the webmin module. Jan 28, 2014 at 7:20
  • Probably best post a self-answer to that effect. LMK when you do, I'll +1. Jan 28, 2014 at 7:30

1 Answer 1


Problem solved. Apparently there is some sort of issue with the PostgreSQL webmin module.

Dumping and restoring the DB with pg_dump in command line solved the issue. Will now backup with scripts rather that using webmin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.