0

Msg 3202, Level 16, State 1, Line 1
Write on "\w-mum-fp\SQLBKP\Weekly-FL\Interactions_26_01_2014.bak" failed: 1130 (Not enough server storage is available to process this command.)
Msg 3013, Level 16, State 1, Line 1
BACKUP DATABASE is terminating abnormally.

Available storage is 400 GB and database backup size with compression is 50GB, still backup is failing. Kindly assist.

migrated from stackoverflow.com Jan 28 '14 at 13:28

This question came from our site for professional and enthusiast programmers.

  • what version of sql server? – drewlander Jan 28 '14 at 7:28
  • SQL server 2008 SP3 – user3243216 Jan 28 '14 at 7:49
  • Are you compressing your backup? That is possible in mssql 2008 (non express). Two things I would check... if you are backing up to a FAT file system, and check this hack out... ghacks.net/2008/01/13/… – drewlander Jan 28 '14 at 7:54
  • most likely memory related within Windows SMB. see support.microsoft.com/kb/304101 – Edward Dortland Jan 28 '14 at 13:45
  • What's the size of the backup uncompressed? If it's bigger than 400 GB, that's likely your reason. If the data file is bigger than that, the initialization of the backup file might require more space than you have available. – Marian Jan 28 '14 at 14:53
1

The error message "Not enough server storage is available to process this command" is a Windows error message that can be extremely misleading. The error message indicates there is not enough RAM available to complete the operation.

It is highly likely that Windows is very low on free memory - check the SQL Server "max server memory" setting to ensure there is a reasonable amount of memory left for the operating system.

This command shows how much memory SQL Server is configured to use:

EXEC sys.sp_configure 'max server memory (MB)';

See What is a deterministic method for evaluating a sensible buffer pool size? for details about what this value should be.

If you see this error, open Windows Task Manager and check how much free memory Windows has.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy