2

I'm having a difficult time resolving a red "invalid" icon within Informatica. I've done all possible scenarios for checking in / checking out this object (mapping). It currently does not have any dependencies. How can I fix this?

enter image description here

  • When you validate the mapping, are there any errors in the Validate tab of the output window (at the bottom)? – Marek Grzenkowicz Jan 30 '14 at 7:44
  • 1
    This was due to an incomplete mapping because my expression transformation didn't have output ports (only input ports) just before the target definition. – MacGyver Jan 30 '14 at 19:41
1

This was due to an incomplete mapping because my expression transformation didn't have output ports (only input ports) just before the target definition.

  • What if the exchange only happens on the inbound? Do we still need to seetup an out port? – user68344 Jun 11 '15 at 15:59
  • That's a great question. I didn't receive the error in that use case. My issue happened when a target definition was created. Are you getting this error on a source definition our something else (different object type)? – MacGyver Jun 12 '15 at 0:21
0

I would like to had a general guide to debugging "invalid" object in PowerCenter.

Indeed as the debugger from the PowerCenter Workflow does not run on invalid Mapping(I would say in general does not run on invalid objects), the only way to get more information is to go on the repository Manager and follow this steps:

  • Open the specific folder

  • Right-click on the object and try before to refresh( this will make sure any change not saved will be saved), then choose "Validate", at this point teh Repository Manager will try to validate the object otherwise finnally you will get an error message reporting what is causing the invalidation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.