2

We have SQL Server 2005 SP4, using merge replication.

We started getting this error when the subscribers try to replicate (not all of them but most):

The process could not deliver dummy update at the 'Publisher'. (Source: MSSQL_REPL, Error number: MSSQL_REPL-2147200993)

We tried to 'reinitialize' one of the subscribers but that doesn't help. It starts applying the schema and seems do that fine, but when it comes time to download new changes it gets the error.

  • Are you running Merge replication with Filters ? Check this MSDN question to see if it helps you. – Kin Shah Feb 3 '14 at 16:54
  • No filters. I already tried the reindexing without success. – rufo Feb 3 '14 at 19:01
1

We have found a lot of records in MSmerge_metadataaction_request pointing to the same article (table), in action = 5.

They look like garbage. When profiling the database those records are returned to the working process even though the article was not included in the subscription that was running (another subscription).

Deleting the records from MSmerge_metadataaction worked out. However, I am not sure if that will generate issues in the long run, at least now the subscriptions are synchronizing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.