0

I have a MYSQL replication set up where I have a single master and three slave DBs. The slave DBs are load balanced behind a Zeus Load Balancer.

I can see on slave DB servers that the Aborted_connects are rising regularly. The same is not happening on Master DB server.

mysql> show status like '%Aborted_connects%';
+------------------+--------+
| Variable_name    | Value  |
+------------------+--------+
| Aborted_connects | 340973 |
+------------------+--------+

To isolate any possible php code connection related issue and or any suspicious connection, I have disconnected on of the slave DB server and run tcpdump. I don't see any unrecognisable connection coming in to the server except for monitoring tool and master db connection (replication).

However, I have see time to time some of the below messages on mysql error log

140213  9:42:17 [Warning] Aborted connection 2099906 to db: 'unconnected' user: 'gvdb' host: '10.140.10.133' (Got an error reading communication packets)

Not sure how this might help, but someone has advised on this Fixing MySQL errors recorded in error logs to increase max_allowed_packet to 128MB.

Even after turning off replication, the Aborted_connects keep rising.

  • 1
    Well, does the username "gvdb" or the IP address "10.140.10.133" mean something? At first glance, it sounds like this may be the load balancer doing health checks in a somewhat ungraceful fashion. – Michael - sqlbot Feb 14 '14 at 22:46
  • Yes, others have also posted similar issues here forums.webyog.com/index.php?showtopic=6999. the IP 10.140.10.133 ip is load balancer related. We use Zeus Load Balancer. Th MySQL Load balancer pool was there for a long time. I used get this sort of error messages once in a while but now it's more frequent. – mezi Feb 17 '14 at 13:27
1

How to solve Aborted_Connects problem

1) Increase the wait_timeout variable value in [my.cnf]

2) Set the log-warnings variable to greater than 1. This will start logging the aborted connections in the mysql error log file once you identified and fixed the problem you can set it back to 1 again.

Also, You can have a look at this forum discussion which is relevant to Load balancer which checks database health every second http://forums.mysql.com/read.php?144,194590,194590#msg-194590

  • Thanks Mahesh, as discussed this issue is caused by the load balancer's health check rather than any hack attempt. I will have to change the load balancer's settings so it makes a proper connection. – mezi Feb 21 '14 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.