I'm trying to enable Text Search in my DB2 instance. I'm running this command:

# /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j "TEXT_SEARCH,db2j_db2inst1,55000"

I get this error:

DBI1011I  An invalid argument was entered for the db2iupdt command.


You can use the db2iupdt command to update a DB2 instance to a higher
level within a release, convert a DB2 instance to a DB2 pureScale
instance, or manage DB2 members or cluster caching facilities (CFs) of a
DB2 pureScale instance.

This message is returned when the db2iupdt command is invoked with
incorrect or missing parameters.

User response:

Enter the command again using valid parameters.

   Related information:
   db2iupdt - Update instances command
   Updating an instance to a higher level within a release using the
   db2iupdt command
   Updating an instance to a DB2 pureScale instance with the db2iupdt
   Dropping a member or cluster caching facility
   Adding new members or an additional cluster caching facility

DBI1011I documentation just says there's something wrong with the parameters. I'm not seeing anything obviously wrong with them when looking at the documentation for db2iupdt.

I'm running DB2 10.5:

$ db2licm -l
Product name:                     "DB2 Advanced Workgroup Server Edition"
License type:                     "CPU Option"
Expiry date:                      "Permanent"
Product identifier:               "db2awse"
Version information:              "10.5"
Max amount of memory (GB):        "128"
Enforcement policy:               "Soft Stop"

How do I successfully enable Text Search in my DB2 instance?


According to the syntax diagram at http://pic.dhe.ibm.com/infocenter/db2luw/v10r5/topic/com.ibm.db2.luw.admin.cmd.doc/doc/r0002060.html, you should enclose the text search options in double quotation marks:

-j "TEXT_SEARCH,db2j_db2inst1,55000"

Don't forget to escape them in the shell.

| improve this answer | |
  • Unfortunately, I get the same error with /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j "TEXT_SEARCH,db2j_db2inst1,55000". I've edited the question to reflect this. – Leo Feb 22 '14 at 0:47
  • Also, same error with shell-escaped /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j \"TEXT_SEARCH,db2j_db2inst1,55000\" – Leo Feb 22 '14 at 0:53
  • 1
    Shouldn't the instance name come after the option? – mustaccio Feb 22 '14 at 15:02
  • You're right, that's the issue. On Linux, the instance name has to be the last thing on the command line. The Information Center is pretty confusing on this: pic.dhe.ibm.com/infocenter/db2luw/v10r5/… – Leo Mar 17 '14 at 19:25

On Linux, the instance name has to be the last thing in the db2iupdt command:

# /opt/ibm/db2/V10.5/instance/db2iupdt -j "TEXT_SEARCH,db2j_db2inst1,55000" db2inst1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.