3

In one of SQL Server 2012 server, agent Xps is getting disabled automatically. There is no set pattern for the same and the issue started all of a sudden. Through profiler it was found that application named SQL AGent- Enable\disable Agent Xps is disabling the XPs. And the later is enabled by SQL Agent-Initial BootProbe.

2

I had a similar problem that I just resolved. Turned out, a new group policy had been applied to our server. This group policy disallowed domain users access to the D:, E:, & F: drives. Our SQL Server Agent was configured to write out its error log to the E: drive. As the Log On account for the SQL Server Agent service was a domain based account, SQL Server Agent was now unable to write to its log file. It died immediately at service start up. It was very frustrating in that we saw nothing in the Windows Event Viewer other than that the service started up and then stopped.

| improve this answer | |
1

To enable Agent of the SQL Server, run following.

sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'Agent XPs', 1;
GO
RECONFIGURE
GO
| improve this answer | |
  • It is getting disabled, after enabling. – user34707 Feb 24 '14 at 9:26
  • 1
    You might check to see if a Policy has been enabled that has this impact on your SQL Server Agent. – RLF Feb 24 '14 at 13:06
  • This may seem out of left field but is there any chance that there is an agent job that disables it? – Kris Gruttemeyer Jul 1 '14 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.