5

I am using SSMS 2012. I am working with .PRC, .TAB, and .UDF files. I added these file extensions to SSMS so that it would treat them like .SQL files already via Tools > Options > Text Editor > File Extension, but recently SSMS has stopped recognizing these files (e.g. won't show them with color coding or allow me to run them against a database). Funnily enough when I remove a file extension from a file it then recognizes them because it has "Map extensionless files to SQL Query Editor" checked.

Does anyone know what the problem might be?

11
  • Try adding it without the leading period (.): technet.microsoft.com/en-us/library/ms175896.aspx
    – user507
    Feb 24, 2014 at 16:17
  • None of them have been added with the leading period (SSMS doesn't let you add one with e leading period).
    – tuseau
    Feb 24, 2014 at 16:29
  • So it worked for some time, then it stopped working? Anything happen at that time (e.g. did you install a new version of Management Studio, or uninstall anything, or install Visual Studio or SQL Server Data Tools, etc.)? What is your version of Management Studio (Help > About) and are you saying it's broken in both 2012 and 2008, or only one? Feb 24, 2014 at 16:33
  • 2
    This should have been fixed with SP1 (which you have applied to your client tools). See if the manual steps described here work... also see this Connect item. Feb 24, 2014 at 18:47
  • 1
    Thanks, the registry keys seemed to work for me today. I'm sure I had tried them already. Seems to be some temperamental behavior with SSMS.
    – tuseau
    Feb 25, 2014 at 12:14

2 Answers 2

2

According to this Connect item, this bug was fixed in Service Pack 1.

However, if the issue persists, you can try this convoluted workaround posted over at SQLServerCentral by Marios Philippopoulos:

OK, got it to work with help from http://www.progtown.com/topic374931-sql-server-2012-rtm.html.

Opened regedit.exe as Administrator.

Then:

On [HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0\FileExtensionMapping\PRC] I changed the Default key value to {B5A506EB-11BE-4782-9A18-21265C2CA0B4}.

On [HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0\Default Editors\PRC] I changed the Custom key value to {B5A506EB-11BE-4782-9A18-21265C2CA0B4}.

0

For me who had just the same problem, the easiest solution was to add the extensions I wanted (PRC,TAB,TRG,UDF) and mark them against SQL Query Editor as you can see on the picture below.

With that done I have the .tab files having the same treatment as the .sql ones.

There was no need to fiddle with the regedit. enter image description here

I am on SSMS v18.12.1

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.