0

I am creating my first SSIS package to support the E of our ETL from an external Oracle database to our internal SQL Server 2012 databse.

Using Visual Studio 2012 and I have installed the Microsoft Oracle Connection Manager by Attunity 2.0

I had this working, then renamed and deleted some files, and tried to build it again when I ran into this problem.

When running Source Assistant, I receive the Visual Studio Error:

The component could not be added to the Data Flow task. Could not initialize the component. There is a potential problem in the ProvideComponentProperties method.

There is an "Additional Information" section that references:

Error at TERM [SSIS.Pipeline]: Component ", clsid {4CAC6073-BCA7-430E-BD29-68A9F0012C6D}" could not be created and returned error code 0x80070005 "Access is denied.", Make sure that the component is registered correctly.

Error at TERM [ [3]]: The component is missing, not registered, not upgradeable, or missing required interfaces. The contact information for this copmonent is "".

Note: "TERM" is the name of the Data Flow task (named after the table I want to copy with SSIS.

This clearly looks like registry damage to me, so I had uninstalled the Attunity copmnent and re-installed it; and I ran a repair on Visual Studio 2012 (in that order); rebooted, etc.

No luck so far.

Anyone ever seen this before and/or have any ideas how to get back to a working SSIS development?

I am working on a development box, my Oracle Connection tests fine, and I can also connect fine to my SQL Server 2012 instance as well.

3
  • Considering doing a repair my SQL Server 2012 client stuff to see if that works. – qxotk Feb 28 '14 at 18:42
  • Note also that I have not been able to figure out how to see the Oracle Source component in the toolbox. Perhaps I should not be using the Source Assistant? – qxotk Feb 28 '14 at 18:46
  • Ran a SQL Server 2012 Repair, which did not finish, because it was looking for SSDT 2012 install files (which SSDT 2012 removes after the install :( ). Then I did a re-install of SSDT 2012 and rebooted - still no luck. – qxotk Feb 28 '14 at 20:34
0

Repairing and/or Re-installing Microsoft Connection Manager for Oracle by Attunity, VS 2012, and SSDT 2012 followed by a reboot enabled me to finally see the Oracle Source and Oracle Destination SSIS components in the SSIS Toolbox window under the Common category.

While using Source Assistant component still causes the same error, dragging over an Oracle Source component succeeds. Configuring the component to set the Connection Manager, Data Access mode ("Table" in my case) and "Name of the Table" work great now.

Clicking on the Preview button proved it's working by showing me actual data from my Oracle Source database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.