0

I have to use Sybase's SQL Anywhere for a project so it has been put on a VM. Memory consumption is particularly high for a not overly taxed database and it's putting a lot of pressure on the VM.

The process is dbsrv12.exe and it's consuming >3GB of memory. Is there a way I can limit that to something more sensible and suitable for a VM?

1 Answer 1

2

Sybase's SQL Anywhere has startup parameters to control the min/max cache settings.

  -c  for the initial cache memory setting
  -ch for the maximum cache memory setting
  -ci for the minimum cache memory setting

If you set these appropriately it should constain the memory usage from the cache.

Here is a SQL Anywhere 12.0 page with those settings: http://dcx.sybase.com/1200/en/dbusage/limiting-using-perform.html

4
  • Thanks for your help this is installed as a service so I used the sc config command to change it as follows: sc config SQLANYs binPath= "C:\Program Files\SQL Anywhere 12\Bin64\dbsrv12.exe -ch 1g -c 256m" but on restart Process Explorer still shows the process with a Private Bytes consumption of >3GB
    – noonand
    Commented Mar 3, 2014 at 15:59
  • @noonand Are you using AWE cache? Are you running x64 version of SQL Anywhere?
    – RLF
    Commented Mar 3, 2014 at 20:16
  • Path for the executable is C:\Program Files\SQL Anywhere 12\Bin64\dbsrv12.exe so I presume it is the x64 version. The OS is 2008 R2 x64. Isn't AWE a nasty software hack to let x86 address more than 4GB along with nasty hardware hacks like 36-bit PAE extensions in the CPU? Surely that has no place in a (albeit virtual) x64 OS/CPU?
    – noonand
    Commented Mar 4, 2014 at 9:36
  • 2
    Awarding answer on this as it prodded me to go look at Sybase central. There I could configure this (and a world of other options)
    – noonand
    Commented Mar 13, 2014 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.