7

I have a connection to a Sybase database which we stage in a SQL Server 2008R2 database. I can connect the the database and the connection tests out fine. I am using an OLE DB source with a Sybase Driver.

Connection Manager

I can even preview data. Note I have shrunk this data set so the data can not be seen but it still demonstrates that the source does return rows.

Preview Data Set

However when I execute the package it results in failure.

Failure

[source 1] Error: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager "MyDataSource" failed with error code 0xC0202009. There may be error messages posted before this with more information on why the AcquireConnection method call failed.

Any ideas as to why this is happening?

UPDATE Adding other error message in spite of them being the opposite of useful. [SSIS.Pipeline] Error: component "source" (1) failed validation and returned error code 0xC020801C. [SSIS.Pipeline] Error: One or more component failed validation. Error: There were errors during task validation.

UPDATE After a few attempts the account sybase account gets locked. Must have something to do with the password.

  • 32 vs 64 bit an issue? – billinkc Mar 5 '14 at 20:27
  • We are running the package in 32. – Zane Mar 5 '14 at 20:28
  • 2
    Never dealt with sybase proper - User and password required? Have you consumed data from sybase before or first time? Any other errors or warnings before/after this that may be relevant? – billinkc Mar 5 '14 at 20:35
  • User and Password is required but set by a project variable. We consume a lot of data from sybase typically through an ODBC connection. I will ad the other errors although they offer little help. – Zane Mar 5 '14 at 20:36
  • @Zane how can you say they are not helpful??, I mean There were errors during task validation, what else do you want?, that it points you to the error? – Lamak Mar 5 '14 at 20:42
1

Under Solution Explorer On Righ Side In BIDS ---->RightClick ---->Properties ---->Configuration Properties ---->Debugging ---->Debug Options ---->Run64BitRuntime ---->False

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.