7

I'm trying to install oracle 11g on fedora by following this tutorial but it stuck after I click Next in step 8. The screen does not go away even after several hours. There's no log file in oraInventory folder.

What could be the possible problem? How can I debug it?

enter image description here

4
  • If no log was generated then what is the point of continuing with the install ! - i suggest your restart your install - troubleshoot your install see the - docs.oracle.com/cd/B19306_01/install.102/b14317/ts.htm – Up_One Mar 11 '14 at 11:31
  • If you have the latest version of Fedora check the internets to see if others have the same problem.Fedora is quite bleeding edge so it has some bugs. – Mihai Mar 11 '14 at 12:12
  • @Up_One I tried several time but every time it stuck at the screen. – Uzair Farooq Mar 12 '14 at 8:45
  • One thing it might be is memory fail- check if the process will top your box – Up_One Mar 12 '14 at 11:15
3

I've struggled the same problem and I think the problem comes from gnome failing to pop up the confirmation dialog. That's why there is nothing in the error logs. So what I did is changing the window manager from gnome to xfce. That solved the problem. It would probably work with another manager or there may be a fix for gnome but here is how to install xfce:

yum -y install epel-release #adding epel repository
sed -i -e "s/enabled=1/enabled=0/g" /etc/yum.repos.d/epel.repo # using it only when needed
yum --enablerepo=epel -y groups install "Xfce" #installing xfce

echo "exec /usr/bin/xfce4-session" >> ~/.xinitrc 
startx

If you prefer to install oracle via vnc then skip the last two lines and change the /home/vnc-user/.vnc/xstartup ( vnc-user is oracle at my box ) like this:

#unset DBUS_SESSION_BUS_ADDRESS
#exec /etc/X11/xinit/xinitrc
/usr/bin/xfce4-session

If you don't know how to install vnc server on your CentOS 7 or Fedora box here is a guide: https://www.howtoforge.com/vnc-server-installation-on-centos-7

1
  • yes - this is the only solution worked, installing and using Xfce for running the installer. Seems that installer is buggy on Gnome... thanks @moo – tmanolatos May 23 '19 at 15:41
2

Try this troubleshooting guide:

http://docs.oracle.com/cd/B28359_01/em.111/b31207/b_oui_appendix.htm#CHDBDFIF1

Also check /etc/oraInst.loc to check where the installer thinks your orainventory location is. If you got to step 6 of the installation, then some log will have been created. I suspect you are looking in the wrong place. See:

http://docs.oracle.com/cd/B28359_01/install.111/b32002/app_ts.htm#LADBI492

2

The same issue I have just came across on CentOS 7. The installer form is disabled and does not allow any input. But clearly it is waiting for some input. In my case it is a GUI glitch. I was not able to find and resize any dialog. However, pressing Enter was enough to return focus to the main window. Though I can't really say what I confirmed or cancelled. :)

0
0

The problem is the size of message box. Is enough with resizing the message box. Go to lower rigth corner for message box and resizing. The screen does not go away because is waiting your response in the message box.

0
0

The installer is displaying the directory where it suggests to install the inventory. If the directory doesn't exist, it seems that it will ask you either to create it or not (can't tell exactly as the message box was so tiny) I killed the installer and created the folder manually and ran the installer again. it worked fine after that.

0

I faced the same issue. This is caused by the JRE version bundled to Oracle Universal Installer.

I could complete the installation by installing another version of the JRE.

-3

I just pressed left and then enter. It worked for me. This is the fix that helped me but I believe it should be fixed permanently.

Not the answer you're looking for? Browse other questions tagged or ask your own question.