0

Today I get error below when install Oracle 11gR2 on Redhat Linux 6.5.

I follow instruction in this link: http://public-yum.oracle.com/

After I call this command:

# yum install oracle-rdbms-server-11gR2-preinstall

=> ok

# yum update

=> I got these errors:

...
--> Finished Dependency Resolution

Error: Package: libreport-2.0.9-19.el6.i686 (rhel-x86_64-server-6)
           Requires: libreport-python = 2.0.9-19.el6
           Removing: libreport-python-2.0.9-19.el6.x86_64 (@rhel-x86_64-server-6)
               libreport-python = 2.0.9-19.el6
           Updated By: libreport-python-2.0.9-19.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-19.0.1.el6
           Available: libreport-python-2.0.5-20.el6.x86_64 (rhel-x86_64-server-6)
               libreport-python = 2.0.5-20.el6
           Available: libreport-python-2.0.5-20.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.5-20.0.1.el6
           Available: libreport-python-2.0.9-5.el6.x86_64 (rhel-x86_64-server-6)
               libreport-python = 2.0.9-5.el6
           Available: libreport-python-2.0.9-5.el6_3.2.x86_64 (rhel-x86_64-server-6)
               libreport-python = 2.0.9-5.el6_3.2
           Available: libreport-python-2.0.9-5.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-5.0.1.el6
           Available: libreport-python-2.0.9-5.0.1.el6_3.2.x86_64 (ol6_latest)
               libreport-python = 2.0.9-5.0.1.el6_3.2
           Available: libreport-python-2.0.9-15.el6.x86_64 (rhel-x86_64-server-6)
               libreport-python = 2.0.9-15.el6
           Available: libreport-python-2.0.9-15.el6_4.1.x86_64 (rhel-x86_64-server-6)
               libreport-python = 2.0.9-15.el6_4.1
           Available: libreport-python-2.0.9-15.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-15.0.1.el6
           Available: libreport-python-2.0.9-15.0.1.el6_4.1.x86_64 (ol6_latest)
               libreport-python = 2.0.9-15.0.1.el6_4.1
Error: Package: libreport-2.0.9-19.el6.i686 (rhel-x86_64-server-6)
           Requires: libreport-compat = 2.0.9-19.el6
           Removing: libreport-compat-2.0.9-19.el6.x86_64 (@rhel-x86_64-server-6)
               libreport-compat = 2.0.9-19.el6
           Updated By: libreport-compat-2.0.9-19.0.1.el6.x86_64 (ol6_latest)
               libreport-compat = 2.0.9-19.0.1.el6
           Available: libreport-compat-2.0.9-15.el6.x86_64 (rhel-x86_64-server-6)
               libreport-compat = 2.0.9-15.el6
           Available: libreport-compat-2.0.9-15.el6_4.1.x86_64 (rhel-x86_64-server-6)
               libreport-compat = 2.0.9-15.el6_4.1
           Available: libreport-compat-2.0.9-15.0.1.el6.x86_64 (ol6_latest)
               libreport-compat = 2.0.9-15.0.1.el6
           Available: libreport-compat-2.0.9-15.0.1.el6_4.1.x86_64 (ol6_latest)
               libreport-compat = 2.0.9-15.0.1.el6_4.1
Error: Package: libreport-2.0.9-19.el6.i686 (rhel-x86_64-server-6)
           Requires: libreport-plugin-reportuploader = 2.0.9-19.el6
           Removing: libreport-plugin-reportuploader-2.0.9-19.el6.x86_64 (@rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.9-19.el6
           Updated By: libreport-plugin-reportuploader-2.0.9-19.0.1.el6.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.9-19.0.1.el6
           Available: libreport-plugin-reportuploader-2.0.5-20.el6.x86_64 (rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.5-20.el6
           Available: libreport-plugin-reportuploader-2.0.5-20.0.1.el6.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.5-20.0.1.el6
           Available: libreport-plugin-reportuploader-2.0.9-5.el6.x86_64 (rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.9-5.el6
           Available: libreport-plugin-reportuploader-2.0.9-5.el6_3.2.x86_64 (rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.9-5.el6_3.2
           Available: libreport-plugin-reportuploader-2.0.9-5.0.1.el6.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.9-5.0.1.el6
           Available: libreport-plugin-reportuploader-2.0.9-5.0.1.el6_3.2.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.9-5.0.1.el6_3.2
           Available: libreport-plugin-reportuploader-2.0.9-15.el6.x86_64 (rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.9-15.el6
           Available: libreport-plugin-reportuploader-2.0.9-15.el6_4.1.x86_64 (rhel-x86_64-server-6)
               libreport-plugin-reportuploader = 2.0.9-15.el6_4.1
           Available: libreport-plugin-reportuploader-2.0.9-15.0.1.el6.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.9-15.0.1.el6
           Available: libreport-plugin-reportuploader-2.0.9-15.0.1.el6_4.1.x86_64 (ol6_latest)
               libreport-plugin-reportuploader = 2.0.9-15.0.1.el6_4.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Thanks in advance.

3 Answers 3

2

This instruction is for Oracle Linux. And you are using Red Hat Enterprise Linux. Even though Oracle Linux is compiled from RHEL sources but they have separate base repositories.

You will have to resolve dependencies manually. I tried to download preinstall RPM and install it with yum but it requires kernel-uek RPM which is not available on RHEL.

Even if I am not the fan of what Oracle does with RHEL but for Oracle databases I switched from RHEL to Oracle Linux. Less resistance this way. Oracle ASM kernel modules are not available for RHEL and Flash Cache feature is available only on Oracle Linux.

3
  • Thanks Mindaugas Riauba. You are right about Oracle Linux but there is a last instruction show how to "convert an RHEL or RHEL-compatible system to Oracle Linux using public-yum". I installed with any errors with kernel-uek. It's only show error with repository when use "yum update". Mar 21, 2014 at 4:20
  • I use Oracle Installation Prerequisites because it is auto config kit making by Oracle. You can read more about it's profit at: Using Oracle Preinstall RPM with Red Hat 6 Mar 21, 2014 at 4:23
  • I know what the package does. I use Oracle Linux. But if you'll do yum update you will "half" convert your RHEL to Oracle Linux. So you will loose Red Hat support and will not gain Oracle support. So decide that path you will take either use RHEL and install dependencies by hand (really it is not so hard) or reinstall Oracle Linux or convert RHEL. Converting is also easy. Mar 21, 2014 at 6:47
1

Answer by Michael Hampton:

That web site does not explain how to install Oracle Database. Rather it explains how to install Oracle Linux, a clone of Red Hat Enterprise Linux. These packages are obviously conflicting with each other.

To resolve the problem, remove the Oracle Linux repository files that you had installed from that site, then run yum distro-sync to repair your RHEL system.

https://serverfault.com/questions/583315/how-to-use-oracle-installation-prerequisites-on-redhat-linux-6-5

0

As said before the package is for Oracle Linux.

Main point is, it depends on the UEK kernel, not on the stock kernel.

Either you resolve the dependencies manually or have a look at the blog entry on flashdba.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.