This problem is really proving to be a tricky one (and quite annoying).

In SQL Server Management Studio 2008, up until a few days ago my IntelliSense was working great. Then all of a sudden it stopped. The icon as it as enabled on the toolbar menu, and under Tools -> Options -> Text Editor -> T-SQL -> IntelliSense it says it is enabled there.

I have tried refeshing the IntelliSense cache with Ctrl-Shft-R but that doesn't work either.

Any ideas what happened to my IntelliSense and what I need to do to get it back?

  • I had the same problem. I have lots of databases. I set most of them offline, refreshed the cache, and Intellisense started working smoothly again. – Firoz Feb 26 '17 at 20:36
  • None of the solutions below worked.. Above comment to put the databases "OFFLINE" method I cannot check because I don't have enough privileges.. – Pரதீப் Jun 12 '17 at 4:41
  • In my experience SSMS intellisense only works half the time and it's simply because it's a buggy feature. It's very frustrating that Microsoft still hasn't been able to fix it after 10 years. – Keith Jun 6 at 15:43
up vote 9 down vote accepted

If you recently upgraded your VisualStudio then see this link for a fix:

The IntelliSense feature in SSMS 2008 R2 may stop working after you install Visual Studio 2010 SP1

Or you could download the fix directly from here:

How to obtain the latest service pack for SQL Server 2008 R2

There are number of possibilities where IntelliSense not working:

There are cases where the local cache used by IntelliSense becomes stale. Refreshing the cache is easy but not necessarily obvious.

There are two ways to refresh the cache:

  1. Hit Ctrl+Shift+R
  2. Go to Edit -> IntelliSense -> Refresh Local Cache

If IntelliSense is still not working, then make sure you have IntelliSense enabled. To check this from the T-SQL Query editor window of the current database:

  1. Go to Tools -> Options -> Text Editor -> Transact-SQL -> General -> IntelliSense
  2. Go to Query -> IntelliSense should be selected
  3. Also verify that the T-SQL Editor does not launch in SQLCMD Mode. To check:

    • Go to Tools -> Options -> Query Execution -> SQL Server -> General
    • Make sure "By default, open new queries in SQLCMD mode" is unchecked.
    • or Go to Query -> SQLCMD Mode should not be selected

Read More

I had this problem, so I followed Ritesh D's advice and went to Tools -> Options -> Text Editor -> Transact-SQL -> General. I checked IntelliSense, and found it was enabled already.

However, I found that "Auto list members" and "Parameter information" were unchecked. So I checked them. This solved my problem.

enter image description here

These two features are what I think of as "intellisense", and Microsoft does not disagree:

IntelliSense is the general term for a number of features: List Members, Parameter Info, Quick Info, and Complete Word. These features help you to learn more about the code you are using, keep track of the parameters you are typing, and add calls to properties and methods with only a few keystrokes.

  • This fixed it for me. Those two options were unchecked. Thank you! – coinbird Dec 7 at 15:57

Please check that Maximum script size is set to "Unlimited" under menu option Tools -> Options -> Text Editor -> Transact-SQL -> General -> IntelliSense. I did this and intellisense started working

When you use remote database with low transfer connection (for example I connected from Europe to far Asia's office server) and when the database's structure is not small (for example many tables) then it takes much more time for SSMS to complete all IntelliSense data.

In my case I had to wait over 1 minute to have IntelliSense accessible (slow connection and db with about 1000 tables). (SSMS doesn't display any progress indicator or any info related to loading process of IntelliSense)

OFFLINE databases can cause intelissense to stop working. You can test it by putting any database in your connected server to OFFLINE and reverting it.

I can confirm it as a SQL 2016 bug

I had the same issue with SQL Server 2008 R2. It got resolved only after applying SQL server 2008R2 Service Pack 1.

  • SQL Server 2008 and SQL Server 2008 R2 are different versions. The question is about the former, and your answer, about the latter. – Andriy M Oct 24 '16 at 13:54

protected by Community Feb 27 '17 at 4:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.