This problem is really proving to be a tricky one (and quite annoying).

In SQL Server Management Studio 2008, up until a few days ago my IntelliSense was working great. Then all of a sudden it stopped. The icon as it as enabled on the toolbar menu, and under Tools -> Options -> Text Editor -> T-SQL -> IntelliSense it says it is enabled there.

I have tried refeshing the IntelliSense cache with Ctrl-Shft-R but that doesn't work either.

Any ideas what happened to my IntelliSense and what I need to do to get it back?


8 Answers 8


If you recently upgraded your VisualStudio then see this link for a fix:

The IntelliSense feature in SSMS 2008 R2 may stop working after you install Visual Studio 2010 SP1

Or you could download the fix directly from here:

How to obtain the latest service pack for SQL Server 2008 R2


There are number of possibilities where IntelliSense not working:

There are cases where the local cache used by IntelliSense becomes stale. Refreshing the cache is easy but not necessarily obvious.

There are two ways to refresh the cache:

  1. Hit Ctrl+Shift+R
  2. Go to Edit -> IntelliSense -> Refresh Local Cache

If IntelliSense is still not working, then make sure you have IntelliSense enabled. To check this from the T-SQL Query editor window of the current database:

  1. Go to Tools -> Options -> Text Editor -> Transact-SQL -> General -> IntelliSense
  2. Go to Query -> IntelliSense should be selected
  3. Also verify that the T-SQL Editor does not launch in SQLCMD Mode. To check:

    • Go to Tools -> Options -> Query Execution -> SQL Server -> General
    • Make sure "By default, open new queries in SQLCMD mode" is unchecked.
    • or Go to Query -> SQLCMD Mode should not be selected

Read More

  • Point 3 was the issue for me. Thanks for this! Commented Jan 26, 2021 at 21:29

I had this problem, so I followed Ritesh D's advice and went to Tools -> Options -> Text Editor -> Transact-SQL -> General. I checked IntelliSense, and found it was enabled already.

However, I found that "Auto list members" and "Parameter information" were unchecked. So I checked them. This solved my problem.

enter image description here

These two features are what I think of as "intellisense", and Microsoft does not disagree:

IntelliSense is the general term for a number of features: List Members, Parameter Info, Quick Info, and Complete Word. These features help you to learn more about the code you are using, keep track of the parameters you are typing, and add calls to properties and methods with only a few keystrokes.


Please check that Maximum script size is set to "Unlimited" under menu option Tools -> Options -> Text Editor -> Transact-SQL -> General -> IntelliSense. I did this and intellisense started working

  • 2
    This fixed mine! Thanks. It defaults to 1MB, which is tiny. So I just changed it to unlimited and now I have it back again.
    – Stuart
    Commented Nov 13, 2020 at 3:35
  • The problem persisted after I applied some of the other fixes here, but this solution did the trick for me. Commented Jan 5 at 22:48

When you use remote database with low transfer connection (for example I connected from Europe to far Asia's office server) and when the database's structure is not small (for example many tables) then it takes much more time for SSMS to complete all IntelliSense data.

In my case I had to wait over 1 minute to have IntelliSense accessible (slow connection and db with about 1000 tables). (SSMS doesn't display any progress indicator or any info related to loading process of IntelliSense)

  • The database i am using is remote and its of huge size too, not 1000 tables though. But I have taken all recommendations into account, to no use uptil now. Nothing works
    – Talha Imam
    Commented Mar 10, 2020 at 10:19

OFFLINE databases can cause intelissense to stop working. You can test it by putting any database in your connected server to OFFLINE and reverting it.

I can confirm it as a SQL 2016 bug


I noticed this issue when I revoked some permissions to the public user, as suggested by Azure. This helped solve my issue:

use master
GRANT EXECUTE ON [xp_instance_regread] TO [public]
GRANT EXECUTE ON [xp_regread] TO [public]

I fixed this in 2 simple steps:

  1. Go to Tools > Options > Text Editor > Transact-SQL > IntelliSense, tick everything and setup the settings this way:

enter image description here

  1. Go to Query > SQLCMD Mode, and disable that:

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.