1

I have installed OEM 12c and after restarting my oms the agents got the following error:

Heartbeat Status : Agent is blocked
Blocked Reason : Plugin mismatch found between agent and repository. 

I have restarted the agent but sill no success.
Any ideas there ?

2
  • have tried ti resync the agent ?
    – Up_One
    Commented Mar 22, 2014 at 16:59
  • done that still the status is the same ?
    – user_bump
    Commented Mar 22, 2014 at 17:00

2 Answers 2

1

I suggest you re-sync your agent using the EM GUI !
Here is a article showing how this is done !

In short :

Check your agent status :

./emctl status agent

Oracle Enterprise Manager Cloud Control 12c Release 3
Copyright (c) 1996, 2013 Oracle Corporation. All rights reserved.
---------------------------------------------------------------
Agent Version : 12.1.0.3.0
OMS Version : (unknown)
Protocol Version : 12.1.0.1.0
Agent Home : /em_agent12.3/agent_inst
Agent Binaries : /em_agent12.3/core/12.1.0.3.0
Agent Process ID : 64164
Parent Process ID : 64110
Agent URL : https://bih002:3872/emd/main/
Repository URL : https://dcg023:4900/empbs/upload
Started at : 2013-11-13 15:26:08
Started by user : em_user
Last Reload : (none)
Last successful upload : (none)
Last attempted upload : 2013-11-13 15:26:14
Total Megabytes of XML files uploaded so far : 0
Number of XML files pending upload : 72
Size of XML files pending upload(MB) : 0.11
Available disk space on upload filesystem : 91.16%
Collection Status : Collections enabled
Heartbeat Status : **Agent is blocked**

Next re-sync your agent using the GUI:
enter image description here

Now check you agent status again!

1
  • After doing this, you may need to also do: emctl secure agent Commented Aug 5, 2020 at 20:28
-1

Deploy plugin to agent.

Go to Setup -> Extensibility -> Plugins -> Databases
Deploy On -> Management Agent (add your agent)
.. wait for a while.
1
  • the agent was already working before OMS restart !
    – user_bump
    Commented Mar 22, 2014 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.