2

I am currently investigating an issue wherein sometimes the SSRS just suddenly stops accepting requests until we do an IISRESET command. This happens after we added an additional processor on the server. No new report is added on that time. Right now we have 2x Quad Core with HT enabled processors. Information in 'sys.dm_os_sys_info' is giving me the correct cpu_count which is 16. However, while looking at the 'ReportServer_XXX.log', I noticed that it's logging incorrect cpu count.

w3wp!resourceutilities!1!3/22/2014-14:29:16:: i INFO: Reporting Services starting SKU: Standard w3wp!resourceutilities!1!3/22/2014-14:29:16:: i INFO: Evaluation copy: 0 days left w3wp!resourceutilities!1!3/22/2014-14:29:16:: i INFO: CPU throttling turned on w3wp!resourceutilities!1!3/22/2014-14:29:16:: i INFO: Running on 127 physical processors, 255 logical processors

I am not certain if this is the cause but either way, how do I correct this issue? The count is way off.

Also, on our other server, the CPU throttling turned on message is not being logged. Could also be this another reason?

SSRS is running under this environment:

  • Windows Server 2003 R2 32-bit (PAE enabled)
  • SQL Server 2005 SP4 (AWE enabled)
  • 2xQuad core with HT processors
  • 64GB memory
  • 1
    32-bit and 64GB of memory, you know is a waste since neither OS or SQL Server is going to use more than 4GB? – Shawn Melton Mar 23 '14 at 19:06
  • Hi Shawn, in SQL server, it's not really a waste of memory. I don't think I have to explain the AWE. But I agree, to truly take advantage of that amount of memory, 64-bit environment is the ideal. However, the application that is running on the server doesn't support 64-bit. – pinoy_ISF Mar 23 '14 at 20:53
  • Have you tried setting the maxdop away from default and see of you encounter the issue ? – Kin Shah Mar 24 '14 at 2:06
  • Kin, thanks for your response. I will try and play on this setting and see if there is any improvement. – pinoy_ISF Mar 24 '14 at 2:53
  • 2
    The second line of your error message states that this is an evaluation copy with 0 days left to run. Is it possible that this is correct? If so, it could be the root cause of your issue. – Simon Byles May 30 '14 at 6:37
0

I think the "CPU Throttling" message indicates that the server has a power setting enabled that will dynamically reduce CPU speed to conserve power (usually the "Balanced" power scheme set in BIOS). Not sure if this is related to your issue, but you probably don't want it enabled on a server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.