2

Sorry to raise if this has been asked before. The SQL Server service is defined as manual, whenever I start it I get (event viewer):

Server TCP provider failed to listen on [ 'any' 1433]. Tcp port is already in use.

The SQL Server (MSSQLSERVER) service terminated with service-specific error

Only one usage of each socket address (protocol/network address/port) is normally permitted.

Odd thing both my ethernet and WiFi adapters have ipv6 disabled and it has ran fine for ages.

Environment details:

  • Windows 2008-R2;
  • SQL Server 2012 BI SP1;
  • all MSFT patches applied.
4

Find out what process is already using TCP 1433. You can do this through the use of TCPView. That utility is a sysinternals tool that gives you the information you need. Just start it, pause the data view, and look at which process is using the local port of 1433 with the TCP protocol.

Note: You'll probably want to uncheck "Resolve Addresses" in the Options menu item so that you will be able to see the default instance port number.

Then once you know the process that is already using that port, you can take the appropriate action or reach out to the appropriate personnel that may know more about the process, why it's there, etc.

Or you could always change the port in which your SQL Server instance is listening on, but I'd personally be extremely curious as to which process is already using that port.

  • To be honest, I can't say for sure why that process is listening on TCP 1433, or anything further. I'd take that information you have (you should remove that comment you just posted, and ensure that sensitive information is removed) and post a follow-up question on serverfault.com asking about the process and why it's using TCP 1433. – Thomas Stringer Mar 27 '14 at 19:07
  • 1
    Many thanks for your time Thomas, I'll try that. – user36285 Mar 27 '14 at 19:12
  • Of course, always glad to help! – Thomas Stringer Mar 27 '14 at 19:13
  • Thomas, thanks again for taking the time. In the end the issue solved itself! Quite odd. – user36285 Mar 31 '14 at 23:47
  • @user36285 Ha! I tend to be doubtful of things just fixing themselves :-) But keep an eye on it! And of course, always glad to help! – Thomas Stringer Apr 1 '14 at 0:03
4

To determine what executable is listening on a port, use netstat -a -n -b and look for 1433.

For example:

C:\Users\administrator.ADVENTUREWORKS>netstat -a -n -b

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:1433           0.0.0.0:0              LISTENING
 [sqlservr.exe]

If it is sqlservr.exe that is listening then the next step is to use SQL Configuration Manager to see what instances of SQL Server are installed. One of them is using tcp1433.

  • Many thx, I used your example, to verify that everything runs fine. – user36285 Mar 31 '14 at 23:55
3

A recent Windows update has caused this behavior:

https://blogs.msdn.microsoft.com/psssql/2018/07/26/july-10-2018-windows-updates-cause-sql-startup-issues-due-to-tcp-port-is-already-in-use-errors/

"July 10, 2018 Windows updates cause SQL startup issues due to “TCP port is already in use” errors"

Fix is in the link.

Get on Brent Ozars mailing list. The team notifies the readers fast.

2

I encountered a similar issue:

Error "Getting an error “server TCP provider failed to listen on (any IPV61433) TCP port is already in use."

Here's how I resolved it:

  • Ran the following command to find which process is using the port.

    netstat -aon | Find /I "1433"
    tasklist|find /I "4"
    
  • Found system 4 services NT kernel & system is using the port 1433

  • Restarted the box. No luck.

  • Disabled anti-virus software and restarted SQL service. This worked.

0

I had this issue today and found that rebooting the server fixed it. I believe it may be something to do with the latest rollup of patches by Microsoft.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.