I am SSH Tunneling to my postgreql server. I have previously successfully configured 9 + win XP dev PCs to connect to this postgresql server, those PCs still connect successfully.

I am now setting up a Windows 7 64bit Dev PC, using all the same putty configurations for the connection, the same version of pgAdmin, however when I try to add the posgresql server to the servers list in pgAdmin it returns the dreaded Postgresql: 'fe_sendauth: no password supplied' error. ???

There is no password and all the previous XP PCs successfully connect using No Password.

I am using postgresql 9.3, pgAdmin 1.18, and I've tried ver 1.16 with same result.

Has anyone else experienced this issue and possibly found a solution?


1 Answer 1


Your Windows 7 PC supports IPv6 natively.

I'd say your pg_hba.conf is set to require md5 on connections from ::1 but not on This works on your XP machines because they won't connect over IPv6. On Win 7, they'll happily use IPv6 (and PuTTY will happily tunnel IPv6), so they probably appear to have the origin address of ::1.

To confirm if this is the case, look at the PostgreSQL log file on the server.

(Personally I find it much less of a pain to just configure SSL on my PostgreSQL servers anyway, mind).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.