12

When I turn on my desktop (Windows 7 SP1), I often find 2 or 3 GB of memory is already occupied by MySQL processes. I don't care about how much memory a database requires, if it actually runs some queries, but I do, if it's an app I even don't start myself yet. For that matter, I barely use MySQL barring when I develop some web apps in my local environments.

enter image description here

So is it possible to stop this gluttony? I tried to remove MySQL from my startup group viamsconfig, but couldn't find its name over there.

Here is extra info.

mysql  Ver 14.14 Distrib 5.6.15, for Win64 (x86_64)
MySQL Server 5.6
MySQL Workbench 6.0
9

You can disable MySQL service from the Command Line (make sure you Run it as Administrator).

To disable service start on Windows startup (this will not stop the service if it is currently running):

sc config mysql start = manual

To stop the service:

net stop mysql
  • Thanks. Your command certainly seems to work, according to windows-commandline.com/start-stop-enable-disable-mysql-service . – Quv May 6 '14 at 13:33
  • 1
    If you get a 'The service name is invalid.' error, your service might be named something else. Type 'net start' to locate it. Mine was MySQL56, so the command to run to stop it was 'net stop mysql56'. – Taran Apr 8 '17 at 15:21
16

In Control panel open Administrative tools then double click Services. Scroll down to MySQL and double click to open the properties. Change the Startup type to Manual.

enter image description here

  • 1
    For reference, here was what I did. It appears I can't really select start= manual but any of options listed below. start= <boot|system|auto|demand|disabled|delayed-auto> So I went with start= demand. – Quv May 6 '14 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.