0

I am using Windows Server 2012 x64 and SQL Server 2012.

I am running the Database Tuning Advisor with these settings :

  1. Advisor plan cache.
  2. Database workload master.
  3. Check my database all the tables.

When tool is started after few seconds I am getting :

SQL Server 2012 Tuning process exited unexpectedly. DTAEngine.

After some "googling" I found that I should install Service Pack 1 for SQL Server 2012. So I did that.

Same result.

If someone has experienced something like this please advise me.

Thx for your time.

1 Answer 1

2

As per KB 2728419

You have to install atleast SQL Server 2012 + SP1 + CU1.

On a sidenote, CU8 is out as well which is the latest one for SQL Server 2012 SP1.

Also, you need to be a member of SYSADMIN role. DB_OWNER wont work as per the above KB.

6
  • Thx but when i tried to download the CU1, there were available for x86. My server is x64. Is there any problem with that?
    – user36922
    Commented Apr 10, 2014 at 14:22
  • @user36922 Follow the site that I told you. It has x64 (support.microsoft.com/hotfix/…)
    – Kin Shah
    Commented Apr 10, 2014 at 14:31
  • @user36922 by default the KBs will only show you the file(s) for the platform you're currently on; this is to prevent you downloading the wrong file (x64 if your machine is x86, or vice versa). It can't know that you're downloading from your x86 machine to apply to an x64 machine elsewhere. Click the link "Show hotfixes for all platforms and languages" to reveal the files you need. And stop using x86 on your workstation; it's 2014 already. BTW, don't feel bad, at least you see something. I hit the KB with a Mac and the file list is always completely empty for me. Commented Apr 10, 2014 at 15:33
  • @AaronBertrand thx for your replay. CU1 Did not work. I am downloading CU8.
    – user36922
    Commented Apr 10, 2014 at 17:24
  • Thx a lot. It worked fine!!!
    – user36922
    Commented Apr 11, 2014 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.