I have the following problem: I can connect to an Orcale database as normal user or as sysdba:

sqlplus myuser/myPw@myDB

sqlplus "sys/sysPw@myDB as sysdba"

But when another (Windows-User) is logged on, he could only use

sqlplus myuser/myPw@myDB


sqlplus "sys/sysPw@myDB as sysdba"

he gets the error:

SQL*Plus: Release - Production on Do Sep 29 12:10:07 2011

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR: ORA-01031: Nicht ausreichende Berechtigungen.

I even tried full qualified paths to sqlplus with the same result.


I see the possibility that different windows users use different (windows-) environment variables, especially different PATH variables. Further I see the possibility that some windows dlls could have wrong security settings and can not be accessed by one of the users.

But I do not see, how this could make an Oracle user, ( SYS in this case ) behave differently.

2nd Edit:

I checked that the Path variable is a system variable, i.e. both windows logins use the same paths.

  • Are you sure "mydb" points to the same database? Check tnsnames for example. Commented Sep 29, 2011 at 12:51
  • Yes I use the TNS_ADMIN environment variable cf. dba.stackexchange.com/questions/3194/…
    – bernd_k
    Commented Sep 29, 2011 at 13:11
  • All the same, I'd be inclined to prove it beyond doubt with the 'myuser' connection that does appear to connect on both machines - eg create a dummy table and select from it on the other machine. Also is either machine you are connecting from also the server or are they both windows clients? Commented Sep 29, 2011 at 13:24
  • It is the same remote machine to which I connect using two different windows accounts.
    – bernd_k
    Commented Sep 29, 2011 at 13:29
  • Have you done any connection logging? Commented Sep 29, 2011 at 14:44

3 Answers 3


Have you checked your ORAPWD file? Maybe the initial originator of the database set entries=1. That would allow 1 user to logon as SYSDBA and the second user would not be able to logon as SYSDBA. Just a thought ;-)


Make sure that your init.ora parameter REMOTE_LOGIN_PASSWORDFILE is set to "exclusive".


Are you really connecting via

sqlplus sys@db as sysdba

as opposed to

sqlplus / as sysdba

? For the latter, the Windows account should be in the ora_dba group, see Oracle documentation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.