0

Just installed a single instance of SQL Server 2012. The instance name is called Example and the server is called WIN2K8R2. It's on a virtual machine and I am RDP'd into it. I'm trying to login with SQL Server Management Studio.

When trying to login, I get this error.

A network-related or instance-specific error occured while establishing a connection to the SQL server.

All SQL Server Services are 'running'. It's a clean build of Win2k8 R2.

Server Type: Database Engine Server Name: WIN2k8R2\Example Auth: Windows Auth


Resolved.

1) Deleted VM. 2) Spun up a new VM. 3) Installed SQL Server 2012

Able to login to the database from RDP.

6
  • 1
    Which edition of SQL Server, Dev, Standard, Express? Also, are you trying to connect remotely or locally? – Mike Fal Apr 21 '14 at 13:35
  • It's an Eval copy currently. I am connecting to the server via RDP and opening SQL Server Management Studio. – user37336 Apr 21 '14 at 14:42
  • Since you are local to the server it should be connecting via Shared Memory. Are you sure the server name is correct and that you are working with a named instance? Are you sure you RDP'd into the correct server (command prompt and type: hostname)? – user507 Apr 21 '14 at 15:32
  • Here is a link that might help: sswug.org/articlesection/default.aspx?TargetID=44331 Also it would be helpful if you could put the full error. Usually there is more after that. – Kenneth Fisher Apr 21 '14 at 16:07
  • Are you 100% positive the instance is running and the instance name is called Example? This is not a permissions error - it isn't even getting that far. Sounds like something else is either not right or not as you think. – Aaron Bertrand Apr 21 '14 at 17:03
2

During installation you were prompted to add Windows users to the SQL instance. Did you add any? Unless you added yourself as a SQL user you won't be able to connect.

  • if you added Administrators as SQL users then you must run SSMS w/o the LUA token restriction, in other words you must right click the launch icon and select "run as Administrator"

  • if you did not add any user as SQL user then you must follow the steps described in Connect to SQL Server When System Administrators Are Locked Out

  • if you don't know what you did and cannot follow the steps mentioned above, discard the VM and install SQL again. Pay attention to the installation procedure and make sure you add yourself as a valid SQL user. Read Database Engine Configuration - Account Provisioning for more details.

All SQL Server Services are 'running'.

Make sure SQL Server Browser Service is running.

1
  • Ended up rebuilding a new VM. Will post an update once the installation finishes. – user37336 Apr 21 '14 at 17:32
1

When setting up SQL Server, by default TCP/IP connections are disabled. This will prevent you from connecting remotely to your instance. You will need to enable this.

  1. Open your SQL Server Configuration Manager.
  2. Browse to "SQL Server Network Configuration" (make sure it's for your appropriate architecture, 32bit or 64bit).
  3. Under that, browse to the protocols for your instance (probably MSSQLSERVER unless you have a named instance).
  4. It will likely say "Disabled". If so, right click and enable.
  5. Restart your SQL Server instance.

More detailed instructions can be found here.

1
  • It was enabled by default. – user37336 Apr 21 '14 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.