4

I was about to give up with this but I'll give it a go here if anyone can help.

I've set up a fail-over cluster SQL Server with 2 SQL nodes, Domain controller and file witness. All seems to work fine, cluster manager shows no errors, I can move the SQL Server role from one node to the other. However, when using SQL studio management to run some queries, I can only connect from the node the SQL Server is running from.

I've opened all related ports (1433 and also 1434), changed SQL Server Network configuration (TCP/IP, Named Pipes, added aliases...), tried Windows Authentication and SQL Server, enabled remote connections check box... and still nothing :(

Is there anything I'm missing? I will eventually need to connect externally but if I can't connect even from one of the fail-over nodes to the other... :(

  • It sounds like you might have issues with the virtual network name for the SQL Server FCI. Have you tried using the IP address of the VNN instead of resolving? Does that VNN hostname resolve? – Thomas Stringer Apr 23 '14 at 11:22
  • That's interesting, because if SQL-Cluster is on SQL01 node, the SQL-Cluster then resolves to the cluster ip on SQL01. In SQL02 that SQL-Cluster resolves to itself (not SQL-Cluster VNN). I tried using ip address but didn't work either. – David Aleu Apr 23 '14 at 11:33
  • 2
    If I was troubleshooting this, I'd try connecting ensuring TCP and have open netmon to see whether or not packets are getting to the machine. The SQL VNN shouldn't be resolving to the core cluster group's IP address, it should be resolving into itself. – Thomas Stringer Apr 23 '14 at 12:20
  • Are you using AG? If yes, did you set one of the replicas to be readonly? Are you connecting via the listener? – Steve Mangiameli Jan 16 '15 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.