I am trying to import a given dump file using oracle imp utility. However; I am facing the following issues.

C:\Users\AD>imp DB_USER/*****@dev1 file=C:\test\db42312.dmp log=C:\test\import2.log

Import: Release - Production on Thu Apr 10 13:37:47 2014

Copyright (c) 1982, 2009, Oracle and/or its affiliates.  All rights reserved.

Connected to: Oracle Database 11g Enterprise Edition Release - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options

IMP-00038: Could not convert to environment character set's handle
IMP-00000: Import terminated unsuccessfully


My source DB yields following results for the NLS query

SQL> select * from v$nls_parameters where parameter in ('NLS_CHARACTERSET','NLS_LANGUAGE');

----------          ---------


And my destination DB yields the following results:

SQL> select * from v$nls_parameters where parameter in ('NLS_CHARACTERSET','NLS_LANGUAGE');

----------          ---------


The issue that I face while executing the import command seems like a character set issue.

Is it possible to import the database dump onto my new (but blank) schema? Please note that I already have other databases on the same server.


2 Answers 2


For me it was the imp command that was wrong. The dump I got was taken using expdp and I was trying to import it with imp.

Got imported using impdp command.


As per Metalink document:

Import Fails With Error IMP-38 (Doc ID 1024237.6)

  • Cause: Dump file is corrupt or environment variables not properly set.

  • Solution: There are a few things to consider when approaching this issue:

If the export dump file was transferred from one location to another using FTP, make sure that it was sent using BINARY mode.

Check that that the dump file has not been edited in any way. This is not a supported activity.

Check the environment settings.

  1. Make sure that environment variable LD_LIBRARY_PATH is pointing to the correct ORACLE_HOME for the version of the Export binary that is being used.

    LD_LIBRARY_PATH should be set to $ORACLE_HOME/lib. If this is not set correctly, the export executable will not be able to find the correct NLS files.

  2. If using Oracle7.2.2, ensure that the environment variable ORA_NLS is set properly. It should be set to $ORACLE_HOME/ocommon/nls/admin/data

  3. Set environment variable NLS_LANG to the character set of the export dump file.

    The export may have been created from a database that is using a character set that is different from the one used for the target database.

    This is especially true if one database uses a 7-bit character set and the other uses an 8-bit character set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.