17

I've been keeping a log of expensive running queries, along with their query plans, in a table to allow us to monitor trends in performance and identify areas that need optimising.

However, it's come to the point where the query plans are taking up too much space (as we're storing the entire plan against each query).

I'm therefore attempting to normalise the existing data by extracting the QueryPlanHash and QueryPlan to another table.

CREATE TABLE QueryPlans
(
    QueryPlanHash VARBINARY(25),
    QueryPlan XML,
    CONSTRAINT PK_QueryPlans PRIMARY KEY
    (
      QueryPlanHash
    )
);

As the definition of the query_plan_hash in sys.dm_exec_query_stats is a binary field (and I'll regularly be inserting new data), I was using VARBINARY for the data type in my new table.

However, the insert below fails...

INSERT INTO QueryPlans
    ( QueryPlanHash, QueryPlan )
SELECT queryplanhash, queryplan
FROM
(
    SELECT 
      p.value('(./@QueryPlanHash)[1]', 'varchar(20)') queryplanhash,
      QueryPlan,
      ROW_NUMBER() OVER (PARTITION BY p.value('(./@QueryPlanHash)[1]', 'varchar(20)') ORDER BY DateRecorded) rownum
    FROM table
    CROSS APPLY QueryPlan.nodes('/ShowPlanXML/BatchSequence/Batch/Statements/StmtSimple[@QueryPlanHash]') t(p)
) data
WHERE rownum = 1

....with the error

Implicit conversion from data type varchar to varbinary is not allowed. Use the CONVERT function to run this query.

The problem is that the query plan hashes are already in binary format, however stored as VARCHAR in the XML Query Plan e.g.

0x9473FBCCBC01AFE

and CONVERT to BINARY gives a completely different value

0x3078393437334642434342433031414645

I tried changing the value definition in the XQuery select to binary, but then it returned no values.

How would I extract the value of 0x9473FBCCBC01AFE from an XML query plan as a VARBINARY, rather than a VARCHAR?

28

You need to use a specific style when you expect to keep the same binary value when converting from a string. Otherwise SQL Server tries to encode the string the same way it would encode 'bob' or 'frank'.

That said, your input string doesn't look correct - there is either a byte missing or one byte too many. This works fine if I drop the trailing E:

SELECT CONVERT(VARBINARY(25), '0x9473FBCCBC01AF', 1);
------------ the ,1 is important ---------------^^^

Result is binary:

----------------
0x9473FBCCBC01AF
  • 1
    Ah, the ,1 was what I was missing. That was easier than I was expecting! Thanks! – Mark Sinkinson Apr 23 '14 at 14:46
  • Not sure about the missing/extra byte. In the 2666 records I have, there's 183 that fail the TRY_CONVERT – Mark Sinkinson Apr 23 '14 at 14:52
  • May need to append a character (say, 0) to any string with an odd character count. That changes the value, but should always change the same value the same way (and I don't suspect you'll have any collisions with or without the 0). – Aaron Bertrand Apr 23 '14 at 14:58
  • Is that not a bug? The queryplanhash in the xml is explicitly set to that value...Surely a TRY_CONVERT to a BINARY should not return NULL – Mark Sinkinson Apr 24 '14 at 10:29
  • From comparing the values saved in my table to the xml it's actually a leading 0 that is missing. So the value should be 0x09473FBCCBC01AF. I can fix those up with a simple REPLACE, but I'm sure it's a bug... – Mark Sinkinson Apr 24 '14 at 12:31
0

How would I extract the value of 0x9473FBCCBC01AFE from an XML query plan as a VARBINARY, rather than a VARCHAR?

I faced something like that using HeidiSQL to query on CASD tables, and solved with fn_varbintohexstr(), like this:

SELECT master.dbo.fn_varbintohexstr(table.hexfield) FROM table;

With HeidiSQL, the value was wrong like '0x3F3F3F3F3F3F3F3F' and became correct like '0x158B1DB75616484695684007CE98E21C'.

OBS: Works since MSSQL 2008! Hope it helps!

  • 2
    Note the caveats to using fn_varbintohexstr() mentioned here. – Erik Aug 18 '15 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.