1

I am using the postgres built in replication with two slave nodes and a single master. On the master node (as well as the slaves) the hstore extension is installed. But whenever a query using hstore is ran on one of my slave nodes I get an error that type "hstore" does not exist.

So for example the query

SELECT product::hstore->make FROM products;

Would give me back all of the different product makes if it is ran on my master node. But as soon as I run it on the slave I get

ERROR:  type "hstore" does not exist

I have used \dx on the slaves to make sure the hstore extension is installed, and it does show as being installed. Do you have any advice on how I can fix this error?

  • Have you seen this potential issue with the path? stackoverflow.com/a/21910573/1595565 – Max Vernon May 8 '14 at 17:43
  • I've tried updating the search paths, but to no avail. – jacobsoloid May 8 '14 at 18:48
  • 1
    The solution was the search path. Originally was only changing on the slaves, and they were then syncing the old one from the Master. So changing it on the master and 2 slaves fixed the issue. – jacobsoloid May 8 '14 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.