1

I have already seen the questioned in the stack overflow that might relate to my problem but let me emphasize that none of them could resolve my issue.

issue is: when I wanted to integrate OWASP WebGoat application with oracle XE 11g , I receive the above mentioned error.

connection URL in web.xml is:

jdbc:oracle:thin:@//localhost:1521/XE/${USER} ================================================================= listener.ora:

SID_LIST_LISTENER = (SID_LIST = (SID_DESC = (SID_NAME = PLSExtProc) (ORACLE_HOME = C:\oraclexe\app\oracle\product\11.2.0\server) (PROGRAM = extproc) ) (SID_DESC = (SID_NAME = CLRExtProc) (ORACLE_HOME = C:\oraclexe\app\oracle\product\11.2.0\server) (PROGRAM = extproc) ) )

LISTENER = (DESCRIPTION_LIST = (DESCRIPTION = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1)) (ADDRESS = (PROTOCOL = TCP)(HOST = Amir-PC)(PORT = 1521)) ) )

DEFAULT_SERVICE_LISTENER = (XE) ============================================================= tnsnames.ora:

XE = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = Amir-PC)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE) ) )

EXTPROC_CONNECTION_DATA = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1)) ) (CONNECT_DATA = (SID = PLSExtProc) (PRESENTATION = RO) ) )

ORACLR_CONNECTION_DATA = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1)) ) (CONNECT_DATA = (SID = CLRExtProc) (PRESENTATION = RO) ) ) =================================================================== java version:

java version "1.7.0_55" Java(TM) SE Runtime Environment (build 1.7.0_55-b13) Java HotSpot(TM) Client VM (build 24.55-b03, mixed mode, sharing) =================================================================== output of the lsnrctl services:

LSNRCTL for 32-bit Windows: Version 11.2.0.2.0 - Production on 09-MAY-2014 16:34 :07

Copyright (c) 1991, 2010, Oracle. All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1))) Services Summary... Service "CLRExtProc" has 1 instance(s). Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service... Handler(s): "DEDICATED" established:0 refused:0 LOCAL SERVER Service "PLSExtProc" has 1 instance(s). Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service... Handler(s): "DEDICATED" established:0 refused:0 LOCAL SERVER Service "XEXDB" has 1 instance(s). Instance "xe", status READY, has 1 handler(s) for this service... Handler(s): "D000" established:0 refused:0 current:0 max:1022 state:ready DISPATCHER (ADDRESS=(PROTOCOL=tcp)(HOST=Amir-PC)(PORT=2403)) Service "xe" has 1 instance(s). Instance "xe", status READY, has 1 handler(s) for this service... Handler(s): "DEDICATED" established:0 refused:0 state:ready LOCAL SERVER The command completed successfully ===================================================================== output of the tnsping xe :

TNS Ping Utility for 32-bit Windows: Version 11.2.0.2.0 - Production on 09-MAY-2 014 16:35:19

Copyright (c) 1997, 2010, Oracle. All rights reserved.

Used parameter files: C:\oraclexe\app\oracle\product\11.2.0\server\network\admin\sqlnet.ora

Used TNSNAMES adapter to resolve the alias Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = Amir-PC) (PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE))) OK (0 msec) could some one please help me resolve this issue? I have been struggling more than 3 days and not found any useful answer yet.

marked as duplicate by Max Vernon, RolandoMySQLDBA, Paul White, Philᵀᴹ, Kin Shah May 10 '14 at 1:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The username doesn't go at the end. stackoverflow.com/questions/4832056/… – Philᵀᴹ May 9 '14 at 13:00
  • @Phil could you please give a solution? – Amir Avarzamani May 9 '14 at 13:22
  • jdbc:oracle:thin:system/system@localhost:1521 <=== this will give invalid connection string format error. suppose system/system is user/pass – Amir Avarzamani May 9 '14 at 13:25
  • invalid username password logon error while I am sure system/system is the one I can login to GUI interfce of oracle XE – Amir Avarzamani May 9 '14 at 13:29
  • by the way i have created another database user is SQL CLI mode with amir/amir like this: SQL> create user amir identified by amir default tablespace system quota 5m on system; <=== still invalid user/pass logon error. – Amir Avarzamani May 9 '14 at 13:33