41

Let's say I have a Oracle database. I have a username = x, password = y, database = z. Also I know the port = a, SID = b, Hostname = c.

So how do I need to connect correctly? I used many options like:

sqlplus x/y@'(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=c)(PORT=a))(CONNECT_DATA=(SID=z)(SERVER=DEDICATED)))'

sqlplus (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=c)(PORT=a))(CONNECT_DATA=(SID=b)))

Submitting these command lines usually gives me back error messages like:

ORA-12560: TNS:protocol adapter error
ORA-12514: TNS:listener does not currently know of service

Many thanks in advance!!

  • 3
    Assuming you have the right host/port, it sounds to me like the instance isn't running or not registered with the listener. – Colin 't Hart May 13 '14 at 11:44
  • 1
    using ezconnect: sqlplus x/y@c:a/b – Dieter DHoker May 14 '14 at 15:45
  • 1
    for the record, your second example (at least) works for me if I surround it with quotes. like x@"(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=c)(PORT=a))(CONNECT_DATA=(SID=b)))" – rogerdpack Feb 18 '15 at 22:04
  • Open ->services in window Start-> oracleservicexe It works for me. – Prakash Mar 21 '18 at 20:55
74

did you try

sqlplus username/password@host:port/service
sqlplus x/y@c:a/b

modern versions of sqlplus (version 11 or newer) understand this syntax and you don't need a tnsnames.ora file.

  • 2
    It works perfectly – Gajotres Jan 22 '15 at 13:53
  • 4
    which version? Doesn't work for me on CentOS ERROR: ORA-12154: TNS:could not resolve the connect identifier specified – Edmondo1984 Jun 23 '16 at 11:35
  • Default Port Number: 1521 – Ivan Chau Aug 31 '16 at 7:28
  • 4
    I have SID instead of service so using ":" instead of "/" worked for me sqlplus username/password@host:port:sid – Pratik Goenka Mar 27 '17 at 9:04
  • 1
    sqlplus that comes withv11.2.0.1.0 doesn't support host:port syntax. Seems 11.2.0.4.0 already supports... – gavenkoa Jan 20 at 18:59
12

The most simple is to use tnsnames.ora file to connect to the database. For that edit it and add a new entry: This file normally resides in the $ORACLE HOME\NETWORK\ADMIN directory.

myDb  =
 (DESCRIPTION =
   (ADDRESS_LIST =
     (ADDRESS = (PROTOCOL = TCP)(Host = c)(Port =a))
   )
 (CONNECT_DATA =
   (SERVICE_NAME =b)
 )
)

and then you could connect to the db:

sqlplus x/y@myDb

7

To original poster... in the first option you missed a closing parenthesis

Incorrect: (Your string)

sqlplus x/y@'(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=c)(PORT=a))(CONNECT_DATA=(SID=z)(SERVER=DEDICATED)))'

Correct:

sqlplus x/y@'(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=c)(PORT=a))(CONNECT_DATA=(SID=z)(SERVER=DEDICATED))))'
2

Your sqlplus line looks correct, verify the following:

  1. You can connect as sysdba on the database server itself.
  2. You can connect as the user you are trying to on the database server itself.
  3. You can ping the database server from the computer you are trying to connect from.
  4. You can tnsping the listener from the computer you are trying to connect from.

If all these check out you may want to create a fresh connection line to make sure you don't have a typo.

1

Maybe your database is not up. If the machine was restarted and the instance is not set to autostart (and it was not started manually), you may need to start the service yourself.

If you have access to the Services screen, you can do it from there; or, you can do it from the command line.

Go to Command prompt and enter the following commands:

set oracle_sid=ORCL

net start oracleserviceORCL

The first sets the Oracle SID; the second actually starts the service.

0

extract from sqlplus help :

can be in the form of Net Service Name or Easy Connect.

  @[<net_service_name> | [//]Host[:Port]/<service_name>]
-2

I found that it is easy to do remote desktop connection and open the Command Prompt then connect by:

sqlplus sys/YourPassword as sysdba

-3

You should start the services of the your databases. For this, go to Start menu -> Run and start services.msc Then search there for databases services and start it. After that it will start working.

-4

This works for me on Oracle 11G

sqlplus orcl_usr/orcl_usr_pass@host/sid

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.