2

I have a complex query that is performing in subsecond time on my laptop, while the same query takes 70 seconds on my production server under no load against an identical schema.

The EXPLAIN plan is similar enough to not warrant such a massive increase in execution time, and identical in terms of the number of rows returned at each step.

This query is going against a query only database, so it's not a result of not having analyzed table statistics either.

I installed MySQL Workbench which seems to be a really nice tool, especially considering the fact that it's free. However, this section in the explorer interface for my connection that is completely grayed out:

PERFORMANCE
  Dashboard
  Performance Reports
  Performance Schema Setup

I did add the following line to my /etc/my.cnf file and restart my server:

[mysqld]
performance_schema

And I followed the instructions in the MySQL Performance Schema Quick Start Guide and verified that this feature is indeed enabled.

I kicked off a job last night in order to have some statistics collected, but this morning only find:

Performance_schema_files_instances_lost    89804

while every other performance_schema-related variable is zero.

The error log is blank, so I have so idea how to find out how to make this work.

I am running MySQL 5.5.21, and MySQL Workbench 6.1 on Mac OSX Mavericks.

  • 2
    The "Performance" section requires MySQL Server 5.6.x+. – philip Jun 23 '14 at 18:42
0

The MySQL Workbench Performance requires the connected database to be version 5.6+. Although 5.5 has most of the capability for it, the MySQL team didn't believe it was mature enough to allow it

  • This should have been posted as a comment (further explanation/clarification &c.) as this answer was already given by @AKWF in June. – Vérace Sep 12 '14 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.