1

I have simple master/slave replication set up between two servers. The master has several DB's I wish not to replicate at this time, in fact there is only DB I am trying to replicate. I have several ignore statements in the .ini file but today replication stopped based of a sql statement that I thought should be ignored. Ini and error below...can anyone see what I am doing wrong and the cleanest way to move forward past this error?

error

Error 'Table 'registry_mobiledoc.regsitry_temp' doesn't exist' on query. Default database: 'mobiledoc'. Query: 'DELETE FROM registry_mobiledoc.regsitry_temp'

config of slave

[mysqld] basedir=E:/mysql datadir=E:/mysql/data tmpdir=E:/mysql/tmp

log-bin=E:/mysql/mysql_binlogs/binarylogs

port=4928 skip-locking skip-bdb lower_case_table_names = 1 query_cache_type = 0 max_connections=300 query_cache_limit=1M tmp_table_size=1M max_tmp_tables=150 wait_timeout = 30 interactive_timeout = 30 table_cache = 900 flush_time = 0

log-slow-queries

long_query_time=3 skip-name-resolve expire_logs_days=14 server-id=3 default_table_type = INNODB

myisam_data_pointer_size=6

If memory = 4GB

key_buffer = 256M

max_allowed_packet = 1M

max_allowed_packet = 32M sort_buffer_size = 512K read_buffer_size = 512K myisam_sort_buffer_size = 512M query_cache_size = 0 tmp_table_size = 1M thread_cache_size=250

number of CPU's*2 for thread_concurrency

The following parameter will change based on the number of CPUs. Some times

the hyper threading is enabled which makes sinlge processor look like dual,

so Make sure that this is done properly.

For single processor -> 2

Dual -> 4

Quad -> 8

thread_concurrency=2

innodb_thread_concurrency=2

Innodb parameters

innodb_flush_log_at_trx_commit=0 innodb_log_files_in_group=2 innodb_log_file_size=256M transaction_isolation = REPEATABLE-READ read_rnd_buffer_size = 8M

innodb_data_home_dir=D:/eClinicalWorks/mysql/data

innodb_data_file_path = mobiledoc_InnoDb_data1:300M:autoextend innodb_file_per_table innodb_additional_mem_pool_size=8M

configure innodb_buffer_pool_size according to available memory

innodb_buffer_pool_size=16G

innodb_log_buffer_size=8M

set-variable=key_buffer=16M

innodb_data_home_dir=E:\mysql\data master-host=192.168.12.83 master-user=SlaveUser master-password=P@ssw0rd master-port=4928 master-connect-retry=15 read-only=1 relay_log_purge

replicate-wild-ignore-table=ecw%.measuretemp

replicate-wild-ignore-table=ecw%.mu_%

replicate-do-mobiledoc

replicate-ignore-db = cur_lmrp replicate-ignore-db = ecwmaster replicate-ignore-db = medispan replicate-ignore-db = mysql replicate-ignore-db = multum replicate-ignore-db = registry_mobiledoc

skip-slave-start slave-skip-errors=1062

[WinMySQLadmin]

Server=D:/eClinicalWorks/mysql/bin/mysqld-nt.exe

user=root password=test Server=E:\mysql\mysql\mysqld-nt.exe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.