In an Oracle Database 11g Enterprise Edition Release - 64bit Production, Running on Oracle Linux 6.5, we configured full RMAN backup schedule using OEM (Oracle Enterprise Manager 11g Database Control Release to take full backup once a week, and incremental level 1 for the rest of the week. This setup went smoothly until we were forced by internal policy to change passwords.

We did change the host's credentials (oracle user and root) plus the main schema. sys and system were unchanged (yet), then I did update the preferred credentials in the OEM, but the next job failed!

Before retrying, I double checked that we chose to use the preferred passwords, and that I didn't misspelled when I typed them (I did test the preferred credentials, misspelled host, sysdba, and normal credentials and watched the errors for each, then entered them carefully and tested again and had a success), but the job failed again. I did change the credentials for the job so it use custom credentials and entered the new credentials manually, retried and failed again!

To get more sure, I created a new job, the same settings we chose for the old job, using the preferred credentials, and ran it immediately, and it succeeded! This made me sure that I didn't mess up the preferred credentials, but there's something in the old job that doesn't respond the way I expect it to do, which is to take the preferred credentials at runtime. It even didn't take the custom credentials when I manually specified it!

So what am I missing here? Is there any other step that I overlooked or forgot to do (or didn't know I should)? Is it the expected behavior and I should delete and recreate all the jobs whenever I change passwords?


OEM version (output of emctl getversion):

Enterprise Manager 11g DB Control Version
Enterprise Manager 10g Agent Version
  • Did you check the host (ssh) passwords as well as the database ones? Really pisses me off when "expert" security bods in corporations enforce password changes on service accounts. Utterly pointless. – Philᵀᴹ May 26 '14 at 23:19
  • yes, I did as well, checked them all.. It pisses me as well, and they know how to scare top managment to sign off their messed up policies!.. – amyassin May 26 '14 at 23:25
  • What version of OEM? – Philᵀᴹ May 27 '14 at 1:02
  • You should be using ssh with keys, not passwords, @Phil. Is it possible to configure Oracle to work in the same way? – Colin 't Hart May 27 '14 at 5:55
  • @Phil edited to show the version... – amyassin May 27 '14 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.