1

I am getting the errors below when trying to start MYSQL. I've deleted both the ./ib_logfile0 and ./ib_logfile1 files and still no success. I'm assuming is has something to do with not being able to write to the temp file but I don't know the location of that directory.

140527 15:56:04 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140527 15:56:04 [Note] Plugin 'FEDERATED' is disabled.
140527 15:56:04 InnoDB: The InnoDB memory heap is disabled
140527 15:56:04 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140527 15:56:04 InnoDB: Compressed tables use zlib 1.2.3.4
/usr/sbin/mysqld: Can't create/write to file '/tmp/ibmZXLyt' (Errcode: 13)
140527 15:56:04  InnoDB: Error: unable to create temporary file; errno: 13
140527 15:56:04 [ERROR] Plugin 'InnoDB' init function returned error.
140527 15:56:04 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
/usr/sbin/mysqld: File '/var/log/mysql_slow.log' not found (Errcode: 13)
140527 15:56:04 [ERROR] Could not use /var/log/mysql_slow.log for logging (error 13). Turning logging off for the whole duration of the MySQL server process. To turn it on again: fix the cause, shutdown the MySQL server and restart it.
140527 15:56:04 [ERROR] Unknown/unsupported storage engine: InnoDB
140527 15:56:04 [ERROR] Aborting
4
  • Unknown/unsupported storage engine: InnoDB That means you have an error the my.cnf file usually located in /etc/mysql/
    – RPM
    May 27, 2014 at 20:05
  • I used my backup my.cnf file from before the problems occured, didn't work for me though.
    – xjx424
    May 27, 2014 at 20:07
  • 1. Is /tmp writable? 2. Isn't the disk full? (df -h /tmp)
    – Jeroen S
    May 27, 2014 at 22:15
  • That was the problem, /tmp was not writable.
    – xjx424
    Jun 5, 2014 at 13:37

1 Answer 1

2

Errcode: 13 means Access denied. Assuming MySQL is trying to create a file in /tmp, which is 777 I guess this is incorrect configuration of either selinux or apparmor (on Debian systems).

Try to disable selinux

    echo 0 >/selinux/enforce

If it doesn't help, stop apparmor (if you run Debian or Ubuntu)

    # /etc/init.d/apparmor stop
    # /etc/init.d/apparmor teardown

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.