2

I've just run the installer for Oracle 11gR2 on a Windows Server 2008 (64-bit) OS.

I encountered the "ORA-00922: missing or invalid option" error at the last stage of installation when it was doing something like "cloning the database". I ignored the error and then immediately got a "ORA-28000: the account is locked" error. The installer then completed successfully.

I looked in the logs for the installation ("C:\app\administrator\cfgtoollogs\dbca\orcl") and found one file named "postScripts.log" which contains these two error messages. Here is the contents of that file:

     1
     1
alter user CTXSYS account unlock identified by ******
*
ERROR at line 1:
ORA-00922: missing or invalid option


ERROR:
ORA-28000: the account is locked


Warning: You are no longer connected to ORACLE.
dropping default lexer preference...
SP2-0640: Not connected
dropping default wordlist preference...
SP2-0640: Not connected
dropping default stoplist preference...
SP2-0640: Not connected
dropping default policy...
SP2-0640: Not connected
SP2-0640: Not connected
Enter value for lang_abbr: SP2-0310: unable to open file "C:\app\Administrator\product\11.2.0\dbhome_2\ctx\admin\defaults\drdefset.sql"

Has anyone else encountered this error before, or know how to resolve it? Will the database function correctly?

Thanks in advance!

3

I found a solution on my own!

It seems that there is a bug in the Oracle installer - it doesn't like it if you start your system password with a number.

I completely uninstalled Oracle using the deinstall utility and then reinstalled Oracle, this time specifying a system password beginning with a letter. This solved the problem!

I hope this helps anyone else encountering this annoying issue.

Additionally, user HanFromBs found that the installer doesn't like special characters (- or +) at the start or end of the password, so watch out for this too.

  • 1
    additional Info: the installer doesnt like special characters (- or +) at the start or end of the password. It gave me the same error as numbers at the start of the password – user44224 Jul 23 '14 at 10:21
  • 1
    Thanks for this. I'm sure that these requirements for passwords are not anywhere in the Oracle documentation, which isn't very helpful! – user1578653 Jul 23 '14 at 10:24
  • 1
    Can you edit that info into the answer? It's better there than in the comments and it looks like useful info. – Jack Douglas Jul 23 '14 at 13:12
  • Can confirm that this works. Had the same problem, I.E., used deinstall on the Oracle software, reinstalled and created a new instance. Got the above mentioned error, changed system password to something with a letter as the first character and it worked. – Lewis Norton May 22 '15 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.