Good evening,

I'm trying to figure out how to create a database+tablespace+user in Oracle 11g.

I've tried some tutorials, but nothing seems to work.

I cannot find Database Configuration Assistant either.

I'm running Windows 8 x64 with Oracle 11g R2, please tell me how I can do this task.

Thanks for all suggestions,

Alec Taylor

  • Can you specify which tutorials/methods/commands tried? Oct 23, 2011 at 12:58

1 Answer 1


I had no problems with a VirtualBox 4.14 Windows 8 preview VM and x64 Oracle 11gR2. Windows 8 Start Screen Database Configuration Assistant

My VM uses 40 GB Hard Disk. While installing it downloaded .Net Framework 3.51 I started with a fresh Windows 8 VM in VirtualBox 4.14 and installed guest additions and run Windows update once. Afterwards I installed Oracle and got the items below on my Start page.

I find the databasefiles of my new database Bk_W8 in C:\app\berndk\oradata\Bk_W8. That is the location I would use for additional tablespaces.

The rest can be done by scripts which can be executed by sqlplus from this machine or from another client and is not Windows 8 specific.


By right-clicking on the item on the start page, via advanced | open file location I found the path to the start menu:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Oracle - OraDb11g_home1\Konfigurations- und Migrations-Tools

I guess you will find

C:\ProgramData\Microsoft\Windows\Start Menu\Programs

the other is specific for a German Oracle installation.

To get access to the hidden C:\ProgramData folder see this link showing how to access folder options in Windows 8

Final hint: My VM currently uses 23 GB for the virtual hard disk.

OK I'm going to retry this with the Oracle Database Express Edition 11g Release 2 (September 2011). But that takes some time.

Installation done: The is the Web interface of Oracle 11g XE in Windows 8

enter image description here

For the question of creating addition databaseinstances: from this question on SO we learn, that it is not possible.

Creating tablespaces and users can be done using sqlplus. Which I found at C:\oraclexe\app\oracle\product\11.2.0\server\bin\sqlplus.exe.

Now going to remove that Virtual machine. I think there are better ways to learn Oracle.

  • Maybe it's because I'm running "Oracle Database 11g Express Edition", that it doesn't show up?
    – A T
    Oct 11, 2011 at 8:03
  • 3
    Yes, there is no DBCA with XE.
    – Uwe Hesse
    Oct 11, 2011 at 8:18
  • Yes XE has no Database Configuration Assistant. I have an x86 Version of XE running in XP. It uses some WEB interface for Configuration. Without trying I can't predict how your version behaves under Windows 8. The next few days I have no resources to check that.
    – bernd_k
    Oct 11, 2011 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.