1

Using CentOS 6.4 x64.

Not sure what happened but somehow my VPS filesystem got corrupted and it is now in a permanent read-only state. I've been working with my hosting provider's sys. admin. but suffice it to say I can't run anything related to MySQL services or daemons.

I did however backup the contents /var/lib/mysql folder. I moved the DB directories from inside that to a new install of MySQL and did proper permissions and ownership. From there I was able to see the databases from the MySQL console and even view the tables but I couldn't get any further. Whenever I attempted to run a SELECT query on any of the tables I get "doesn't exist when using LOCK TABLES". Tried dumping the DB using skip-locks and all that but nothing seems to work. Select queries and any sort of dump seems to be useless.

Is there another way to repair or retrieve the contents of these tables/databases? Thank you.

  • Try mysqldump --skip-lock-tables -A > dump.sql . – akuzminsky Jun 12 '14 at 22:49
  • btw, what storage engine are you using? – akuzminsky Jun 12 '14 at 22:52
  • Default MyISAM. I tried skip-lock-tables with the -A flag but it only put out something like a 200 byte file. The dump should be closer to 15MB. – sparecycle Jun 13 '14 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.