0

After reading a few of the similar problems to mine and none of them working, I thought I'd attempt to be more specific to see if my root problem needed to be fixed differently than the others.

I've been using MySQL for about a year now and it's always worked fine -- but I got a new Macbook Pro (10.9.3) yesterday, and everything migrated and runs great except for MySQL. It's running:

MySQLRunning

My root user is enabled and I checked to see that the password is the same as my user login (and the same as it's always been) -- but every time I try to run it, whether it be through Terminal or through Sequel Pro, I always get the same:

Access denied for user 'root'@'localhost' (using password: YES)

I also traditionally use Sequel Pro -- which migrated over from my old computer without any problems, and retained the connection details its always had:

SequelPro

But I'm getting the same error message through Sequel Pro as I am through Terminal:

SequelProError

Does anybody have any ideas of things I can try? After attempting some of the other similar questions on here, I've unfortunately come up with nothing.

Thanks!

  • @MaximeFOUILLEUL But if I take out the password it just says Access denied for user 'root'@'localhost' (using password: NO) instead? – Ryan Jun 25 '14 at 19:57
-1

Run this /usr/bin/mysql_upgrade -u root -p This should reset the rights and grant access with u logged in as 'root'@'localhost' Thereafter run this /usr/bin/mysql -u root -p... et viola!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.