2

I'm trying to run vacuum delete only on a table with big amount of columns (800+) and 4 million rows.

I know it's recommended to use deep copy instead, but still am wondering if running vacuum is still possible on such big table. This is my error:

vacuum_max_buffer is too small to vacuum table <table> - need at least: 3388MB

is it possible to change the value of vacuum_max_buffer (set vacuum_max_buffer=xxxxx), or is it best not to change this and go on with the deep copy?

Thanks, Meny

1
  • Thanks very much for accurately identifying your use of Redshift, not just saying "PostgreSQL". Of course, that means I have no idea how to help, as vacuum_max_buffer seems to be a RedShift/ParAccel specific parameter that isn't in mainline PostgreSQL. Jun 30, 2014 at 9:39

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.