0

I'm attempting to get a PostgreSQL environment running locally. I'm using 9.2.8, and have restored data from a backup made by the DBA of the production environment.

The restoration worked fine with 0 errors; however, in a couple of the Views there is a missing field that is in the production schema from which we restored our data.

As well, when attempting to do a simple select from the Views mentioned using the postgres role, I always get the following error:

ERROR:  permission denied for relation Map
********** Error **********
ERROR: permission denied for relation Map
SQL state: 42501

After doing some research (read: Googling), I tried GRANTing priveleges on the Schema, Views, and associated tables (in this case, the table 'Map') to avail.

Obviously, I'm a neophyte PostgreSQL user. I'm sure there's something simple I'm missing. But what could it be?

  • Can you elaborate on in a couple of the Views there is a missing field? – Erwin Brandstetter Jun 30 '14 at 17:18
1

To troubleshoot, I would start by looking at the output of SELECT current_user; and SHOW search_path;. Also, the output of \dp termin in psql.

My suspicion here is that you are stumbling over mixed case identifiers. The error message mentions a table

Map

Notice the capital letter M. Are you sure there is no mix-up with another table named map (lower case)?
Are PostgreSQL column names case-sensitive?

(Or, in another schema coming earlier in the search_path?)

  • Thanks for the info, Erwin. This was only one of many issues, but it was certainly case sensitivity that was at issue here! – Fletchius Jul 10 '14 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.