0

I run the SQL Server 2012 Express SP1 install and it succeeds. After I have rebooted my computer, I do a

select @@version

But still I only have version 11.0.21600.64. I have tried this on two computers now, still the same result.

The file I am running is: SQLEXPR_x64_ENU.exe downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=35579

  • Do you have more than one instance (run sqlcmd -l at a command prompt, for instance one of dev/test machines shows as ABT, ABT\EXPR and ABT\S2008R2 in that list as it has three instances) and if so how are you connecting? You might have upgraded the default instance only and be connecting to another one (or vice versa). – David Spillett Jul 3 '14 at 8:33
  • I downloaded the SQL server Service Pack 1 instead, and then it found my instance..Seems like I cant run the express SP1 version and I rather need the SQL server service pack 1 file. – miniHessel Jul 3 '14 at 9:06
  • 11.0.21600.64 certainly doesn't look right in any case. And when you apply a service pack, you will have either 11.0.3000 (SP1) or 11.0.5058 (SP2, recommended). Not sure why you expect 11.1. – Aaron Bertrand Jul 3 '14 at 14:23
2

The full Express version (with SP1 included) is for installing a new instance, not for applying a service pack to existing instances. Sounds like perhaps you now have a second instance of SQL Express (no idea without seeing your configuration manager or services applet).

At this point you should download Service Pack 2 (not 1) to apply to existing instances, regardless of edition:

Download SQL Server 2012 Service Pack 2

(And perhaps clean up the extra instance, if in fact you did install a second instance inadvertently.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.