I have configured Reporting Services on one Server and have the ReportServerDb and ReportServerTempDb on other server (Future requirement of scale out deployment).

I am connecting to these servers using a domain account. I have configured Reporting Services using ReportingServiceConfiguration Wizard and it seems to have worked fine except that the Initialization tab does not have the green tick in front (not initialized).

The error I get is:

The report server cannot open a connection to the report server database. The logon failed. (rsReportServerDatabaseLogonFailed) Get Online Help Logon failure: the user has not been granted the requested logon type at this computer. (Exception from HRESULT: 0x80070569)

The domain account I have used is perfectly fine and I am able to connect using SSMS (No Password errors). I have searched through many a blogs, forums etc, but have not been able to find a solution.

3 Answers 3


Re-run through the database configuration part to select the same database and it will re-issue the grants to make sure the permissions are in place, but make sure the account you run the wizard with has sysadmin access to the instance. If it's 2005 you can generate the grant script but it's kind of buggy.


I recently had this exact issue and resolved it by simply adding Integrated Security=SSPI to my connection string. For example:

Data Source=YourServerName;Initial Catalog=DatabaseName;Integrated Security=SSPI;

Check to make sure that the domain account you are using has the 'Logon Locally' privelege in your local security policy, most likely on the DB server, but possibly on your report server as well.

Also, try looking at this article. Properly set SPNs are a necessity for SSRS on a server other than the same machine the db is on.

  • Thanks for your reply. tried #Logon Locally# privilege but that didn't work out. Tried using NT Authority\NetworkService account and everything seems to be fine.Is there any difference? I have set up the domain user just like the NetworkService account but still no results. Appreciate your help!!
    – Vineet
    Feb 16, 2009 at 13:57
  • Hey mate thanks, I set up the SPN for domain user and everything seems to be working fine. There is one change though I had to make - just to let you know - Changed Windows service to run under Network service account (unlike domain account) though Web service still runs under domain user account :)
    – Vineet
    Feb 17, 2009 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.