2

In one of my SQL Server 2008 sp1 standalone instances, syspolicy_purge_history job is fails at step 3 Erase Phantom System Health Records.

Below is the command -

(Get-Item SQLSERVER:\SQLPolicy\servername\DEFAULT).EraseSystemHealthPhantomRecords()

Error :

Executed as user: domain\xxxxx. The process could not be created for step 3 of job 0x3183E8EEDE9C3A4DA0F20ABD41B573DC (reason: %1 is not a valid Win32 application). The step

Service account is same for SQL Server and Agent and it is admin on the server. I'm aware that clustered instances usually fail because of virtual name mismatch but I tried searching Google but I don't see correct solution to this problem.

2
  • 2
    Are you running 32-bit SQL Server on a 64-bit OS? Jul 15, 2014 at 19:04
  • Is there a file named Program in your systemdrive?
    – Jens D.
    Aug 31, 2015 at 13:01

1 Answer 1

1

I ran into this error a while back and found this link, hope it resolves your issue. http://www.mssqltips.com/sqlservertip/2041/why-syspolicypurgehistory-job-fails-in-sql-server-2008-failover-cluster-instance/

2
  • Thanks Jeff, but this is a standalone server...still i'm getting the same error...
    – Robin16
    Jul 16, 2014 at 14:31
  • Are you able to run this script manually using powershell commandline?
    – SQLPRODDBA
    May 31, 2016 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.