I used RMAN with,

RMAN>backup database archivelogs all;

After that I truncated a table.

I then tried to restore with,

RMAN>restore database;
RMAN>recover database;
RMAN>alter database open;

I connected with sqldeveloper, and the table is still empty. I have tried many times. I made sure there wer archive files with crosscheck backup. It simply never restores the data to that table in the schema. I know you cannot restore a single table, so I restored the whole database thinking it would put my data back.

There is one database, one backup, truncate, one restore (did this a lot). I have tried set until for an incomplete backup, many things. I don't need a point in time, however. I was trying to get anything to work.

I received no errors. Everything looked good.


  • All disk backup.
  • Oracle Enterprise Linux 6.5.
  • Oracle 11gR2,


  • I have not used logminer.

What am I doing wrong?


You're issuing a "recover database" command, which will recover the database as far as possible. If that includes the archivelogs/redo logs which contain your "truncate" command, then this will also be re-played and the table truncated again.

Try doing the restore on it's own, or recovering to a specific time using RECOVER UNTIL... then opening the DB read-only to see if it's in the state you expect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.