2

I am getting this error on a named instance. I set up the account and profile. It is pointing to our internal anonymous smtp server. The IP address has been allowed to relay on the SMTP server. Firewall is open. Windows firewall is open on port 25.

The database mail configuration hung when setting the service broker to enabled. I put the msdb in single user mode and then enabled the broker service manually, then set it back to multi_user.

Still getting the error: looks like an smtp error but the smtp settings are correct and the other instance on the same cluster is working fine. Database mail xp's are enabled. So the usual culprits are covered.

Anybody have any other ideas?

  • 5.7.1 unable to relay tells me that the ip address has not been allowed to relay on the SMTP server. To test this, run telnet on the SQL server and try to send email to a remote domain. – Greenstone Walker Jul 18 '14 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.