I try installing SQL2008R2 - SQL2012 - sql2014

2014-07-17 16:31:16.00 spid14s     Error: 17190, Severity: 16, State: 1.
2014-07-17 16:31:16.00 spid14s     Initializing the FallBack certificate failed with error code: 1, state: 20, error number: 0.
2014-07-17 16:31:16.00 spid14s     Unable to initialize SSL encryption because a valid certificate could not be found, and it is not possible to create a self-signed certificate.
2014-07-17 16:31:16.00 spid7s      Starting up database 'msdb'.
2014-07-17 16:31:16.01 spid12s     Starting up database 'mssqlsystemresource'.
2014-07-17 16:31:16.01 spid14s     Error: 17182, Severity: 16, State: 1.
2014-07-17 16:31:16.01 spid14s     TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support. Cannot find object or property. 
2014-07-17 16:31:16.01 spid14s     Error: 17182, Severity: 16, State: 1.
2014-07-17 16:31:16.01 spid14s     TDSSNIClient initialization failed with error 0x80092004, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. Cannot find object or property. 
2014-07-17 16:31:16.01 spid14s     Error: 17826, Severity: 18, State: 3.
2014-07-17 16:31:16.01 spid14s     Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.
2014-07-17 16:31:16.01 spid14s     Error: 17120, Severity: 16, State: 1.
2014-07-17 16:31:16.01 spid14s     SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

5 Answers 5


Following can be reason for this error

The account which user selected on Server Configuration page window ( during installation) is somehow not able to bring SQL Server database engine services online. Either is lacks privilege or it is corrupted. During installation of database engine services SQL Server tries to bring online database services as a internal process but due to startup account either corrupt or not having appropriate privileges it fails to do so and ultimately installation fails.

Other reason is when installation fails first time due to some reason and user uninstall failed installation from add remove program, the un-installation leaves account in broken state so any further attempt to install flashes this error message.


Uninstall SQL Server completely from Add remove program and start new installation by right click on Setup and selecting run as admin. Now when you reach Server Configuration page please select NT Authority\System as SQL Server Database Engine service startup account.

enter image description here


PS: If this does not helps please revert. Please follow steps mentioned in link carefully

  • 3
    Yeah, don't to this.
    – mrdenny
    Aug 21, 2014 at 10:00
  • 3
    No? I did what @Shanky said: removed it all, re-boot, re-install as administrator, run service as SYSTEM. Works for me. No good?
    – Marcus
    Aug 20, 2015 at 14:33
  • 2
    Worked like a charm for me. Except I didn't uninstall or restart. I just installed a separate instance, then once that succeeded, uninstalled the bad one. Also, the second time was much, much, much faster, because a majority of the files were already installed. All the shared tools remain in-tact until you choose to uninstall the last instance. Sep 20, 2016 at 22:39
  • 1
    worked for me after trying to get it installed for 2days. thanks Sep 6, 2019 at 16:57

The reason that SQL isn't starting is that the SSL certificate that you've configured SQL Server to use for encrypting the SQL Server traffic can't be found, so SQL can't start. Open the SQL Server configuration manager Under "SQL Server Network Configuration" right click on "Protocols for MSSQLSERVER" and select properties. On the certificate tab change to a certificate that exists, or if you aren't trying to encrypt the network traffic don't select any certificate. Click OK and then try starting the SQL Server Service.


Adding full access permission to %userprofile%\AppData\Roaming\Microsoft\Crypto\RSA\S-1-5-xxxxx folder (where xxxxx is specific to your environment) for account used by MSSQLSERVER service fixed my problem.

See more at: http://www.iamberke.com/post/2013/07/05/SQL-Server-cannot-start-TDSSNIClient-initialization-failed.aspx#sthash.nxHHQ6WQ.dpuf


Select a valid user account on installation and the correct password instead of NTUSER/LOCAL and that's it. Preferably select also WINDOWS/SQL_SERVER ACCESS.


I tried to installed SQL Server on a domain controller and faced this issue. I solved this issue by creating distinguished user in active directory and providing the respective users in the services of SQL Server during installation. I hope this might help someone.

Not the answer you're looking for? Browse other questions tagged or ask your own question.