0

I am trying to import data from falt files (.CSV) into SQL table. I am able to import them no problem but the data is coming with double quotes. What is the best way of resolving this problem?

Regards,

1

Set the text delimiter in the flat file reader properties to the double quote.

0

If you have mixed data, where some are double quoted and others are single, another option would be to load the complete data into a column and have a computed column in the same table that is running a function to strip out the unwanted characters from the source column. something like this:

create table [xxxx] ( originalcol varchar(50) null, [$$derived] as replace(originalcol,'"','') )

Just saying it may be easier doing it in SQL then SSIS

Not the answer you're looking for? Browse other questions tagged or ask your own question.