I've created sereral SSIS packages in Visual Studio 2012 and they can be executed without any problems.

For a project I'm working on I generate packages using BIML. In my BIML script I create a package for each databaseview in two defines databaseschemas. For example:

  • [crm].[contact]
  • [crm].[account]
  • [navision].[vendor]
  • [navision].[customer]

The name of the packages will be [schemaname] viewname, e.a. "[crm] contact".

When I start a package in Visual Studio I get the message "Failed to start project" see below.

Error message in Visual Studio 2012

"Exception deserializing the package. "Specified part does not exist in the package".

Why is this error occurring?

  • Have you tried using mist? You can take your packages created in visual studio and reverse engineer them into Biml and just reuse that code.
    – gazma
    Commented Jul 13, 2015 at 0:35

2 Answers 2


When troubleshooting the error I've searched the internet for possible solutions. The main solution to this error is the 32bit / 64bit excecution of SSIS.

Because I can run other packages without any problems all posible solutions I found regarding configuration of packages, SSIS and Visual Studio didn't apply.

Maybe I did something wrong when I generated the packages with BIML, so I started with an empty package and see if it ran.... Still the same error.

Eventually i changed the name of the package to "crm contact" and it ran. It seems that using blockquotes ( [ ] ) in the name gave the error.

  • Which you can observe by editing any SSIS object's name property. You'll get back an error message indicating ` The object name "[" is not valid. The name cannot contain any of the following characters: / \ : [ ] .`
    – billinkc
    Commented Aug 8, 2014 at 14:07
  • By the way, bring on the Biml questions. ;) Here or stackoverflow works.
    – billinkc
    Commented Aug 8, 2014 at 14:08
  • I didn't het an error about the objectname. When I'm back in the office I'll try and zee if there is an error somewhere. The strange thing is that SSIS 2008 is running fine. Commented Aug 9, 2014 at 8:52

In my case, I tried above things but it didn't worked, instead I opened project properties and made a small change in it and applied it, it resolved issue for me.enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.