80

The error in its entirety reads:

psql: could not connect to server: No such file or directory. Is the server running locally and accepting connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

This is my second time setting up Postgresql via Homebrew on my Mac, and I have no clue what is going on. Previously, it had been working. At some point, I must've entered a command that messed things up. I'm not sure. Now, whenever I enter a SQL command from the command line, I receive the above message. I've run a command to check whether the server is running, and it apparently is not. If I attempt to start the server using

$ postgres -D /usr/local/pgsql/data

I receive the following error:

postgres cannot access the server configuration file "/usr/local/pgsql/data/postgresql.conf": No such file or directory

I've uninstalled and reinstalled Postgresql via Homebrew, but the problem persists. I'm completely at a loss as to how to get this working. Any help would be appreciated.

16 Answers 16

90

The problem can also be attributed to a crashed process that left postmaster.pid file behind.

$ brew services stop postgresql
$ rm /usr/local/var/postgres/postmaster.pid # adjust path accordingly to your install
$ brew services start postgresql
| improve this answer | |
  • 4
    On MacOSX, this answer saved me. Had the same error as OP after my computer hard rebooted. The brew services command were not helpful because they made it seem like everything was working. Removing the postmaster.pid is what finally got everything working again. Thanks! – vinhboy Mar 5 '18 at 22:47
  • 1
    This happened to me too. Hard crash of Mac OS X caused a restart, after that Postgres didn't come up. brew services start/stop/restart doesn't work, you have to manually remove the pid file. – Matthijs May 29 '19 at 9:49
  • The recommended way would be to run Postgres in a docker container, of course. Very easy to start and everything is cleaned up when a container is shut down. I'd say running any third party app in a docker container should be de facto nowadays. – demisx May 29 '19 at 13:27
  • Save my ass. Also caused after crash of macOS... – ortonomy Apr 1 at 5:37
51

The answer is here.

Run this command to manually start the server:

pg_ctl -D /usr/local/var/postgres -l /usr/local/var/postgres/server.log start
| improve this answer | |
45

I was getting the same

Is the server running locally and accepting connections on Unix domain 
socket "/tmp/.s.PGSQL.5432"?

loop of Homebrew install / start / stop / restart to no avail...

Finally, brew postgresql-upgrade-database worked.

Seems I was on 9.6 instead of 10.4, and something my latest App Store restart restarted all my database servers...

| improve this answer | |
  • 1
    this worked for me – davideghz Mar 4 '19 at 9:13
  • 3
    That brew postgresql-upgrade-database is what I was missing. Thanks for pointing that out. – Corin Mar 18 '19 at 16:20
  • Worked for me thanks! – Erwin Rooijakkers May 6 '19 at 9:39
  • 1
    I've tried all the solutions. But this is the only one worked for me. Would be great to know if anyone could explain why this fixed it completely. – JohnnyQ Aug 11 '19 at 9:24
  • I dont know why this worked can some one explain me why?Thanks in advacne – Ajay Kumar Jan 29 at 16:04
12

I've just resolved the same problem. It's just because I forgot to run it properly before use.

For pure installing postgresql on Mac OS, the process will be (using brew command):

brew install postgresql

then if you want to automatically run postgresql at login:

ln -sfv /usr/local/opt/postgresql/*.plist ~/Library/LaunchAgents

or else you just want to run it anytime you want:

postgres -D /usr/local/var/postgres

If your case is more complicated, let's brew uninstall postgresql and redo these steps.

Hope it helps!

| improve this answer | |
  • 2
    Update: for Homebrew-installed postgres, brew services start postgresql is now the preferred way to start postgres at login – henry Jul 2 '19 at 17:29
6
psql: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket"/var/pgsql_socket/.s.PGSQL.5432"?

I kept on getting the above error and none of the above solutions worked for me. Finally the following solution solved my problem on Mac OS X

Install postgres using brew

brew install postgres

Install brew services

brew tap homebrew/services

To start postgres as a background service

brew services start postgresql

To stop postgres manually

brew services stop postgresql

We can also use brew services to restart Postgres

brew services restart postgresql
| improve this answer | |
3

This happens when postgres server is not running. Steps to properly install Postgres via Homebrew on MAC :

  1. brew install postgres

  2. initdb /Users/<username>/db -E utf8 [This initializes postgres to use the given directory as the database directory. Normally it is not adviced to use the user directory for database storage. Edit sudoers file to add initdb and similar commands and then run initdb on /usr/local/var/postgres]

  3. pg_ctl -D /Users/<username>/db -l logfile start [After getting success with step 2 it will prompt to run step 3. This command manually starts the server.]

| improve this answer | |
2

It worked for me. Change your postgresql directory according to version in your system.

Common path- rm /usr/local/var/postgres/postmaster.pid

but for postgresql@9.6 in my system path is rm /usr/local/var/postgresql@9.6/postmaster.pid

restart postgresql@9.6- brew services restart postgresql@9.6

| improve this answer | |
  • yup thats the ONE that works! – PirateApp Oct 4 '19 at 5:57
1

I just uncomment in /etc/postgresql/9.5/main/postgresql.conf

unix_socket_permissions = 0777

and restart postgres. And for me it works.

| improve this answer | |
1

recently I went thru a similar problem. there's just another problem and solution. I was running 2 version of postgres (9.3 and 9.6) although the server was set to run on 2 different port but some how the psql command on bash try to connect to default port 5432. Make sure to check if your server is running and check your port settings, then run psql -p <port> postgres. The solution is changing port.

| improve this answer | |
1

I was looking for a long time, and this was the most clean and neat solution:

I recently upgraded Postgres from 9.2 to 9.3 using brew upgrade postgres. The process was smooth and pg_upgrade is a very handy tool.

However, trouble struck once I tried to run any specs that needed to connect to Postgres. Even though Postgres was definitely running, suddenly I was getting:

could not connect to server: No such file or directory (PG::ConnectionBad) Is the server running locally and accepting connections on Unix domain socket "/var/pgsql_socket/.s.PGSQL.5432"? The problem was that the new version of Postgres listens on /tmp/.s.PGSQL.5432 instead. I could’ve messed around with the config and made Postgres use the domain socket it was previously, or told Rails explictly how to connect, but both of those approaches seemed like work I shouldn’t have to do. At no point had I told Rails to connect to postgres on that path, Rails had assumed it, and now its assumptions were wrong.

The fix is simple, if a little suprising. When you install the ‘pg’ gem, it detects which version of Postgres is installed and sets the domain socket path appropriately. The solution is as simple as reinstalling the gem. $ gem uninstall pg $ cd my-rails-app/ $ bundle install

http://daniel.fone.net.nz/blog/2014/12/01/fixing-connection-errors-after-upgrading-postgres/

| improve this answer | |
1

For me this also happened after a reboot and none of the above solutions worked for me. After checking the server log like this:

tail /usr/local/var/postgres/server.log

I noticed:

    2019-11-06 11:04:31.797 CET [85029] FATAL:  data directory "/usr/local/var/postgres" has invalid permissions
2019-11-06 11:04:31.797 CET [85029] DETAIL:  Permissions should be u=rwx (0700) or u=rwx,g=rx (0750).

So I changed the permissions like this:

sudo chmod 700  /usr/local/var/postgres

and everything worked again and life was good.

| improve this answer | |
  • Same, using postgresql@12 on osx 10.15. Last thing needed was a brew services restart postgresql – Doug Feb 28 at 15:46
1
  1. Check if postgres is already running using the following command:

    pgrep -u postgres -fa -- -D

usually you'll get one or more lines depending on whether you are running one or multiple instances of the server. If postgres isn't running you'll get no lines.

  1. Now remove (rm) the postmaster.pid file from the data directory which is usually

    ~/Library/Application\ Support/Postgres/var-9.6

  2. start the postgres server

If the data directory already contains the postmaster.pid file then it means postgres is running. When the server crashes or is killed the database process needs to be stopped before the postmaster.pid is removed otherwise the data directory could get corrupted.

| improve this answer | |
0

update it by using command

  brew postgresql-upgrade-database

if you have following error Command 'brew' not found, but can be installed with: sudo apt install linuxbrew-wrapper

then install it by using command

 sudo apt install linuxbrew-wrapper
| improve this answer | |
0

High level summary of the issue:

This issue might occur for one of the reasons below:

a. Maybe the port is not the default port used (which is 5432)- How to confirm this?

ps -ef | grep UID && ps -ef | grep postgres

Got the pid of 5833 from the output below:

UID  PID  PPID   C STIME   TTY  TIME CMD
501  5833 1     0 12:07PM ??   0:00.13 /usr/local/opt/postgresql/bin/postgres -D /usr/local/var/postgres

If you DO NOT get the output like above, most likely the postgres server is not running. You can confirm postgres server status with pg_ctl or other commands to confirm. There are other articles on how to check the status

Find the log location with the pid (5833 is the pid of postgres from the above command, replace the pid with your pid from the command output you get):

$ lsof -p 5833 | grep log

postgres 5833 <username>    1u    REG                1,4  1610136            14411021 /usr/local/var/log/postgres.log

Open the log file and confirm the port number from the log line like below:

[5833] LOG: listening on IPv4 address "127.0.0.1", port 5488

[5833] being the process id in this case

So, you can grep that as well like:

egrep "[5833]*listening*" /usr/local/var/log/postgres.log

Once you get the port, which was 5488 in my case, connect to postgres server with an option "-p" to connect (replace with the port found from the log):

psql -p 5488 <databasename> #add host and other options as needed

b. The process is not running at all or there is some other issue, which can again be seen in the log (which can be found with the steps above). If the postgres server is not started, please try restarting the postgres instance with the command as appropriate to the operating system you are using.

For Mac OS the command to restart was brew services restart postgresql

Hope this helps methodically troubleshoot this issue.

| improve this answer | |
-1

I got the exact same error message, where psql could not connect to the server, and brew install postgresql gave the error message Failed to install plist file.

The problem turned out to be that some software install had changed the ownership of /usr/local/var to root.

Solution: $ sudo chown /usr/local/var `whoami`

I'm surprised that brew doctor did not detect this.

psql: could not connect to server: No such file or directory. Is the server running locally and accepting connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

| improve this answer | |
-3

The steps below helps me:

brew uninstall postgresql brew install postgresql brew postgresql-upgrade-database

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.