1

I'm getting this error while trying to connect to sql server. Now this never happened before and it's really annoying.

I found out in my sql configuration manager that SQL server service has stopped for some reason.

When I try to start it again it gives me error that says: "The request failed or the service did not respond in a timely fashion".

I found some solution for this but none of them works for me. I checked if VIA protocol is enabled, and it was disabled.

I checked

  • if my server allows remote connections and it does.
  • if port 1433 is used by some other service, but still it was not used by any other services.

Those are solutions that I found and tried to solve this problem with them, but no success.

Is there any other reason why is this error happening and how to solve it?

migrated from stackoverflow.com Sep 15 '14 at 12:35

This question came from our site for professional and enthusiast programmers.

  • 1
    Have you tried connecting using the full SERVERNAME\INSTANCENAME string? For example, if your server is named SQLHOST and the name of the instance is "SQLSERVER", try to connect to it as: SQLHOST\SQLSERVER – Dan Sep 15 '14 at 10:29
  • 2
    Can you check the event log for further detail of this error? – Madurika Welivita Sep 15 '14 at 10:30
  • 1
    Duplicate question. If your SQL Service stop immediately after start check username & password of mssql service. – Max Sep 15 '14 at 10:35
  • 1
    You can't connect because you service isn't started. You need to troubleshoot why the service won't start. Start with the Windows event logs. – Thomas Stringer Sep 15 '14 at 12:53
  • 1
    To eliminate network issues, try telnet servername 1433. If you get something like "connection failed" or "connection denied", this could indicate that there's a firewall problem somewhere along the way (not neccessarily on the server itself). – Daniel Hutmacher Sep 16 '14 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy