1

I have installed and created a database in oracle 12c in ubuntu 14.04 . Now I can login to the CLI using sqlplus \ as sysdba and run sqlcommands , but I can't login to the EM from the web. The name given to me while database was loading was tamim-Inspiron-5421:5500/em that is just my machine name, but when I type this on the browser , webpage not found error happens. when I run the command lsnrctl status | grep HTTP it returns empty i.e blank. the output of the command in SQL is select dbms_xdb_config.getHttpsPort() from dual; is

DBMS_XDB_CONFIG.GETHTTPSPORT()
------------------------------
                         5500

I am logged in as oracle user like this oracle@tamim-Inspiron-5421 . I have checked the netstat --listen and saw that no program is listening to port 5500. What could be the problem ?

Here is the error in lsnrctl

LSNRCTL> status
Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Linux Error: 111: Connection refused

I think I need to configure my firewall , or edit my /etc/hosts file somehow , but I don't know how !! here is my /etc/hosts file

127.0.0.1   localhost
127.0.1.1   tamim-Inspiron-5421 

after I added localhost like this 127.0.1.1 tamim-Inspiron-5421 localhost Here is the status

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 12.1.0.1.0 - Production
Start Date                21-SEP-2014 18:47:22
Uptime                    0 days 0 hr. 9 min. 2 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Log File         /oracle/app/oracle/diag/tnslsnr/tamim-Inspiron-5421/listener/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=tamim-Inspiron-5421)(PORT=1521)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcps)(HOST=tamim-Inspiron-5421)(PORT=5500))(Security=(my_wallet_directory=/oracle/app/oracle/admin/tamimdb/xdb_wallet))(Presentation=HTTP)(Session=RAW))
Services Summary...
Service "tamimdb" has 1 instance(s).
  Instance "tamimdb", status READY, has 1 handler(s) for this service...
Service "tamimdbXDB" has 1 instance(s).
  Instance "tamimdb", status READY, has 1 handler(s) for this service...
The command completed successfully
4
  • Is EM running or not? Did you check EM log files for errors? – mutap Sep 21 '14 at 22:17
  • I deleted and reinstalled the database. Now suddenly it works !!! – Tamim Addari Sep 23 '14 at 14:51
  • @mutab: do you happen to know where the EM Express log file is? I can't seem to find it. – Wouter Sep 29 '15 at 11:53
  • Does your server have multiple network adaptors? Check listener.log at the time you try to connect to the webpage. Does it contain a TNS-12518 error? Is the IP address mentioned in this error the same as the IP address your hostname maps to? Or is it the IP address of one of the other adaptors? Is the problem solved if you disable the other adaptors? – Wouter Dec 18 '15 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.