7

Sometime last week my CTRL+TAB behavior changed. I used to hit CTRL+TAB, release, then I would be in my previous document tab. Now I hit CTRL+TAB, release, and the nav window is still open requiring me to hit enter.

I have tried restarting ssms and rebooting several times. This is an issue in both SSMS 2012 and 2014. It is not an issue in Visual Studio (2010 and 2013).

In all VS 2010/2013 and SSMS 2012/2014 the hotkey Ctrl+Tab (Global) is set to Window.NextDocumentWindowNav. Though I have tried modifying it then putting it back.

enter image description here

CTRL+F6 works the same as it always has.

Is there a way to get the CTRL+TAB behavior back?

  • Have you installed any new software recently that perhaps changes the way dialog windows work? Perhaps some multi-monitor management software or something like that? Maybe a new video driver, perhaps? – Max Vernon Sep 22 '14 at 20:57
  • 2
    My fresh install of SQL Server Management Studio 2012 does not exhibit the behavior you mention. – Max Vernon Sep 22 '14 at 20:58
  • Maybe some type of accessibility feature that you may have accidentally enabled in Windows? Also, is this occurring in a Remote Desktop session? The Remote Desktop client sometimes does funny things to certain "special" windows keys like AltGr and Alt+Tab, though I haven't experienced your particular issue before.. – Daniel Hutmacher Sep 22 '14 at 21:35
  • @MaxVernon I don't recall installing anything; but that is most likely the culprit. – Jay Otterbein Sep 23 '14 at 12:28
  • @DanielHutmacher The behavior only exists in SSMS and works correctly in Visual Studio. It's unlikely a hotkey setting of that sort. Though there may be a context-sensitive setting somewhere. – Jay Otterbein Sep 23 '14 at 12:29
-1

To fix this issue: Tools \ Options \ Keyboard. Bring up the command in the "Show commands containing:" list. Then in the "Press shortcut keys:" text box press CTRL+Tab and click Assign. This will re-assign the command back to itself, but fixed the "sticky" window. Just had the same issue. Hope this helps.

Re-assign the command

  • Didn't work for me :( – joelmdev Mar 24 '16 at 15:56
  • Didn't work for me either. Any other suggestions? – J Brune Jun 9 '16 at 17:51
  • 1
    I don't see any help in telling OP to do what he already stated he tried and didn't work. It seems whatever problem you had was different. – Disillusioned Aug 16 '16 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.